summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/comp/comp-4.2.1.ebuild')
-rw-r--r--dev-util/comp/comp-4.2.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/comp/comp-4.2.1.ebuild b/dev-util/comp/comp-4.2.1.ebuild
new file mode 100644
index 00000000..5570f170
--- /dev/null
+++ b/dev-util/comp/comp-4.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="compare files or directories, including metadata"
+HOMEPAGE="https://github.com/vaeth/comp/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!<dev-util/mv_perl-3
+>=dev-lang/perl-5.8"
+# || ( >=dev-lang/perl-5.9.4 >=virtual/perl-File-Spec-3.0 )
+# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
+ -- bin/* || die
+ eapply_user
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README
+ insinto /usr/share/zsh/site-functions
+ doins zsh/_*
+}
+
+pkg_postinst() {
+ optfeature "improved output" 'dev-perl/String-ShellQuote'
+}