summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/diffhelp/diffhelp-1.10.ebuild')
-rw-r--r--dev-util/diffhelp/diffhelp-1.10.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/diffhelp/diffhelp-1.10.ebuild b/dev-util/diffhelp/diffhelp-1.10.ebuild
new file mode 100644
index 00000000..1b9eb450
--- /dev/null
+++ b/dev-util/diffhelp/diffhelp-1.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+
+DESCRIPTION="A frontend, beautifier, and path-fixer for diff -u"
+HOMEPAGE="https://github.com/vaeth/diffhelp/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- "${PN}" || die
+ eapply_user
+}
+
+src_install() {
+ dobin "${PN}"
+ insinto /usr/share/zsh/site-functions
+ doins "_${PN}"
+}