summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gdbus-codegen/gdbus-codegen-2.49.5.ebuild')
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-2.49.5.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-2.49.5.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-2.49.5.ebuild
deleted file mode 100644
index 365077ed..00000000
--- a/dev-util/gdbus-codegen/gdbus-codegen-2.49.5.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-RESTRICT="mirror"
-GNOME_ORG_MODULE="glib"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-PYTHON_REQ_USE="xml"
-
-inherit eutils gnome.org distutils-r1
-
-DESCRIPTION="GDBus code and documentation generator"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE=""
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-
-# To prevent circular dependencies with glib[test]
-PDEPEND=">=dev-libs/glib-${PV}:2"
-
-S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen"
-
-python_prepare_all() {
- PATCHES=(
- "${FILESDIR}/${PN}-2.40.0-sitedir.patch"
- )
- distutils-r1_python_prepare_all
-
- sed -e 's:#!@PYTHON@:#!/usr/bin/env python:' gdbus-codegen.in > gdbus-codegen || die
- cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
- sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
-}
-
-src_test() {
- einfo "Skipping tests. This package is tested by dev-libs/glib"
- einfo "when merged with FEATURES=test"
-}
-
-src_install() {
- einfo "the gdbus-codegen package was a
-rather short lived module, and it's unfortunate that people might
-have installed it on their system, also unfortunate that it was
-not created as egg-dbus-codegen or using some non-glib
-invasive namespace."
-}
-
-python_install_all() {
- distutils-r1_python_install_all # no-op, but prevents QA warning
- #doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
-}