summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mv_perl/mv_perl-1.4.ebuild')
-rw-r--r--dev-util/mv_perl/mv_perl-1.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/mv_perl/mv_perl-1.4.ebuild b/dev-util/mv_perl/mv_perl-1.4.ebuild
new file mode 100644
index 00000000..73548b0d
--- /dev/null
+++ b/dev-util/mv_perl/mv_perl-1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="4"
+RESTRICT="mirror"
+
+DESCRIPTION="A collection of perl scripts (replacement in files, syncing dirs etc)"
+HOMEPAGE="https://github.com/vaeth/${PN}"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="zsh-completion"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-Digest-MD5"
+
+src_unpack() {
+ default
+ cd *"${PN}"-*
+ S="${PWD}"
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README
+ if use zsh-completion
+ then insinto /usr/share/zsh/site-functions
+ doins zsh/_*
+ fi
+}