summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mv_perl/mv_perl-2.6.ebuild')
-rw-r--r--dev-util/mv_perl/mv_perl-2.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/mv_perl/mv_perl-2.6.ebuild b/dev-util/mv_perl/mv_perl-2.6.ebuild
new file mode 100644
index 00000000..be31d1ec
--- /dev/null
+++ b/dev-util/mv_perl/mv_perl-2.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="A collection of perl scripts (replacement in files, syncing dirs etc)"
+HOMEPAGE="https://github.com/vaeth/mv_perl/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="zsh-completion"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-Digest-MD5"
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README
+ if use zsh-completion
+ then insinto /usr/share/zsh/site-functions
+ doins zsh/_*
+ fi
+}