summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mv_perl/mv_perl-3.09.ebuild')
-rw-r--r--dev-util/mv_perl/mv_perl-3.09.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/mv_perl/mv_perl-3.09.ebuild b/dev-util/mv_perl/mv_perl-3.09.ebuild
new file mode 100644
index 00000000..2fdba491
--- /dev/null
+++ b/dev-util/mv_perl/mv_perl-3.09.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="A collection of perl scripts (replacement in files, syncing dirs etc)"
+HOMEPAGE="https://github.com/vaeth/mv_perl/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8"
+# || ( >=dev-lang/perl-5.9.4 >=virtual/perl-File-Spec-3.0 )
+# || ( >=dev-lang/perl-5.6.1 >=virtual/perl-Getopt-Long-2.24 )
+# || ( >=dev-lang/perl-5.7.3 virtual/perl-Digest-MD5 )
+# || ( >=dev-lang/perl-5.7.3 virtual/perl-Time-HiRes )
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
+ -- bin/* || die
+ eapply_user
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README
+ insinto /usr/share/zsh/site-functions
+ doins zsh/_*
+}
+
+pkg_postinst() {
+ optfeature "support to set timestamps of symlinks" 'dev-perl/File-lchown'
+ optfeature "improved output" 'dev-perl/String-ShellQuote'
+ optfeature "compatible patchdirs output" 'dev-perl/String-Escape'
+}