summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pyrep')
-rw-r--r--dev-util/pyrep/ChangeLog54
-rw-r--r--dev-util/pyrep/Manifest2
-rw-r--r--dev-util/pyrep/metadata.xml2
-rw-r--r--dev-util/pyrep/pyrep-1.4-r1.ebuild33
-rw-r--r--dev-util/pyrep/pyrep-1.5-r1.ebuild30
5 files changed, 89 insertions, 32 deletions
diff --git a/dev-util/pyrep/ChangeLog b/dev-util/pyrep/ChangeLog
new file mode 100644
index 00000000..9a9cb692
--- /dev/null
+++ b/dev-util/pyrep/ChangeLog
@@ -0,0 +1,54 @@
+# ChangeLog for dev-util/pyrep
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pyrep-1.4-r1 (18 Jan 2015)
+
+ 10 Oct 2015; Martin Väth <martin@mvath.de>:
+ Update python dep
+
+ 15 Feb 2015; Martin Väth <martin@mvath.de>:
+ Fix python-single-r1 usage
+
+ 18 Jan 2015; Martin Väth <martin@mvath.de>:
+ Use new-style python dependency
+
+*pyrep-1.4 (10 Aug 2014)
+
+ 10 Aug 2014; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild
+
+*pyrep-1.3-r1 (17 Dec 2013)
+
+ 06 Jul 2014; Martin Väth <martin@mvath.de>:
+ New style github tarball
+
+ 17 Dec 2013; Martin Väth <martin@mvath.de>:
+ Fix python path
+
+*pyrep-1.3 (21 Nov 2013)
+
+ 21 Nov 2013; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild
+
+*pyrep-1.2 (02 Nov 2013)
+
+ 02 Nov 2013; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild. Shebang care
+
+*pyrep-1.1 (02 Mar 2012)
+
+ 28 Sep 2012; Martin Väth <martin@mvath.de>:
+ Bump to EAPI=5
+
+ 12 May 2012; Martin Väth <martin@mvath.de>:
+ base->eutils
+
+ 15 Apr 2012; Martin Väth <martin@mvath.de>:
+ Inherit base
+
+ 19 Mar 2012; Martin Väth <martin@mvath.de>:
+ Use vcs-snapshot.eclass
+
+ 02 Mar 2012; Martin Väth <martin@mvath.de>:
+ New ebuild from scratch
diff --git a/dev-util/pyrep/Manifest b/dev-util/pyrep/Manifest
index 7d50a6f0..516923ed 100644
--- a/dev-util/pyrep/Manifest
+++ b/dev-util/pyrep/Manifest
@@ -1 +1 @@
-DIST pyrep-1.5.tar.gz 9555 SHA512 3a2affa147da9e833432e2441dc1a1a3ea47e618695d6541ea6a4f04cb60b0708314814de191aea4e77a07b17f714454a7611f5f0989528e0ebabddd93a1cca0
+DIST pyrep-1.4.tar.gz 8622 SHA256 8051593becdd43ceaa3e0602f4d20c02f85b70233d443147ffbbb9ab715451f4 SHA512 9038b6368930628488f5e47a08262c9a51aec20172e8528d199d113653e445d37a69d4f07c00087cc8359e04fcf864ea72c749d9552b580d8f38ff62d8ec55f7 WHIRLPOOL 7a752cde3c1e84d2900dd3704ef2bdfb72ae06741c801cbcc6c3b11decf88674a108dce704dd4038a5e9c9b21c6b45d37a9e10fadc9853748f8c0bfb0f121fe9
diff --git a/dev-util/pyrep/metadata.xml b/dev-util/pyrep/metadata.xml
index 05021980..d9f498ac 100644
--- a/dev-util/pyrep/metadata.xml
+++ b/dev-util/pyrep/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
+ <maintainer>
<email>martin@mvath.de</email>
<name>Martin Väth</name>
</maintainer>
diff --git a/dev-util/pyrep/pyrep-1.4-r1.ebuild b/dev-util/pyrep/pyrep-1.4-r1.ebuild
new file mode 100644
index 00000000..c10ea901
--- /dev/null
+++ b/dev-util/pyrep/pyrep-1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+PYTHON_COMPAT=( jython2_7 pypy{,3} python{2_7,3_{4,5}} )
+inherit eutils python-single-r1
+
+DESCRIPTION="Search and/or replace regular expressions within many files interactively"
+HOMEPAGE="https://github.com/vaeth/pyrep/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ python_fix_shebang "${S}"
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env python$"#!'"${EPREFIX}/usr/bin/python"'"' \
+ -- "${PN}" || die
+ epatch_user
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc AUTHORS README
+}
diff --git a/dev-util/pyrep/pyrep-1.5-r1.ebuild b/dev-util/pyrep/pyrep-1.5-r1.ebuild
deleted file mode 100644
index dc53ffc1..00000000
--- a/dev-util/pyrep/pyrep-1.5-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 2012-2018 Martin V\"ath
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-RESTRICT="mirror"
-
-DESCRIPTION="Search and/or replace regular expressions within many files interactively"
-HOMEPAGE="https://github.com/vaeth/pyrep/"
-SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="dev-lang/python"
-
-src_prepare() {
- use prefix || sed -i \
- -e '1s"^#!/usr/bin/env python$"#!'"${EPREFIX}/usr/bin/python"'"' \
- -- bin/* || die
- default
-}
-
-src_install() {
- dobin bin/*
- dodoc AUTHORS README.md
- insinto /usr/share/zsh/site-functions
- doins zsh/_*
-}