summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/replacer/replacer-1.0.ebuild')
-rw-r--r--dev-util/replacer/replacer-1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/replacer/replacer-1.0.ebuild b/dev-util/replacer/replacer-1.0.ebuild
new file mode 100644
index 00000000..6d6e7aa9
--- /dev/null
+++ b/dev-util/replacer/replacer-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+inherit python-any-r1
+
+DESCRIPTION="Search and replace python regular expressions within many files interactively"
+HOMEPAGE="https://github.com/vaeth/replacer/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env python$"#!'"${EPREFIX}/usr/bin/python"'"' \
+ -- bin/* || die
+ default
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README.md
+ insinto /usr/share/zsh/site-functions
+ doins zsh/_*
+}