summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/comp/comp-4.3.ebuild6
-rw-r--r--dev-util/diffhelp/diffhelp-1.11.ebuild6
-rw-r--r--dev-util/mv_perl/mv_perl-3.16.ebuild4
-rw-r--r--dev-util/pyrep/pyrep-1.5-r1.ebuild2
-rw-r--r--dev-util/replacer/replacer-3.1-r1.ebuild4
5 files changed, 11 insertions, 11 deletions
diff --git a/dev-util/comp/comp-4.3.ebuild b/dev-util/comp/comp-4.3.ebuild
index d2b3e25d..37525b44 100644
--- a/dev-util/comp/comp-4.3.ebuild
+++ b/dev-util/comp/comp-4.3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2017 Gentoo Foundation
+# Copyright 2016-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
RESTRICT="mirror"
DESCRIPTION="compare files or directories, including metadata"
@@ -27,7 +27,7 @@ src_prepare() {
use prefix || sed -i \
-e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
-- bin/* || die
- eapply_user
+ default
}
src_install() {
diff --git a/dev-util/diffhelp/diffhelp-1.11.ebuild b/dev-util/diffhelp/diffhelp-1.11.ebuild
index d734d8e1..5c221fb1 100644
--- a/dev-util/diffhelp/diffhelp-1.11.ebuild
+++ b/dev-util/diffhelp/diffhelp-1.11.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2016 Gentoo Foundation
+# Copyright 2012-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
RESTRICT="mirror"
DESCRIPTION="A frontend, beautifier, and path-fixer for diff -u"
@@ -17,7 +17,7 @@ src_prepare() {
use prefix || sed -i \
-e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
-- bin/* || die
- eapply_user
+ default
}
src_install() {
diff --git a/dev-util/mv_perl/mv_perl-3.16.ebuild b/dev-util/mv_perl/mv_perl-3.16.ebuild
index ff040336..ecd15fa8 100644
--- a/dev-util/mv_perl/mv_perl-3.16.ebuild
+++ b/dev-util/mv_perl/mv_perl-3.16.ebuild
@@ -1,7 +1,7 @@
# Copyright 2012-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
RESTRICT="mirror"
DESCRIPTION="A collection of perl scripts (replacement in files, syncing dirs etc)"
@@ -30,7 +30,7 @@ src_prepare() {
use prefix || sed -i \
-e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
-- bin/* || die
- eapply_user
+ default
}
src_install() {
diff --git a/dev-util/pyrep/pyrep-1.5-r1.ebuild b/dev-util/pyrep/pyrep-1.5-r1.ebuild
index 413760ec..2d5af915 100644
--- a/dev-util/pyrep/pyrep-1.5-r1.ebuild
+++ b/dev-util/pyrep/pyrep-1.5-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 2012-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
RESTRICT="mirror"
DESCRIPTION="Search and/or replace regular expressions within many files interactively"
diff --git a/dev-util/replacer/replacer-3.1-r1.ebuild b/dev-util/replacer/replacer-3.1-r1.ebuild
index 27e9e958..647b8f8f 100644
--- a/dev-util/replacer/replacer-3.1-r1.ebuild
+++ b/dev-util/replacer/replacer-3.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
RESTRICT="mirror"
DESCRIPTION="Search and replace python regular expressions within many files interactively"
@@ -19,7 +19,7 @@ done
RDEPEND="dev-lang/python
nls? ( virtual/libintl )"
-DEPEND="nls? ( sys-devel/gettext )"
+BDEPEND="nls? ( sys-devel/gettext )"
src_prepare() {
local r