summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-wrappers-mv/git-wrappers-mv-1.10.ebuild')
-rw-r--r--dev-vcs/git-wrappers-mv/git-wrappers-mv-1.10.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-vcs/git-wrappers-mv/git-wrappers-mv-1.10.ebuild b/dev-vcs/git-wrappers-mv/git-wrappers-mv-1.10.ebuild
new file mode 100644
index 00000000..5f5498ac
--- /dev/null
+++ b/dev-vcs/git-wrappers-mv/git-wrappers-mv-1.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+
+DESCRIPTION="Some personal wrappers for the most important git commands"
+HOMEPAGE="https://github.com/vaeth/git-wrappers-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}"'/bin/sh"' \
+ -- bin/git-[b-z]* || die
+ eapply_user
+}
+
+src_install() {
+ local i
+ insinto /usr/bin
+ for i in bin/*
+ do test -h "$i" || dobin "$i"
+ done
+ dosym git-tag /usr/bin/git-archive
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ dodoc README
+}