summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/fish-fillets')
-rw-r--r--games-puzzle/fish-fillets/Manifest2
-rw-r--r--games-puzzle/fish-fillets/fish-fillets-1.0.1-r1.ebuild67
-rw-r--r--games-puzzle/fish-fillets/metadata.xml19
3 files changed, 88 insertions, 0 deletions
diff --git a/games-puzzle/fish-fillets/Manifest b/games-puzzle/fish-fillets/Manifest
new file mode 100644
index 00000000..4f3421fb
--- /dev/null
+++ b/games-puzzle/fish-fillets/Manifest
@@ -0,0 +1,2 @@
+DIST fillets-ng-1.0.1.tar.gz 380290 SHA512 fe4a5186f94e953cbc85fe8b0ce804c881c96feda385cfc36e1840e448cf094c3d815fdbe32976a6697a855038951f97a384c277a1c52a048520e8da71136718
+DIST fillets-ng-data-1.0.0.tar.gz 146418413 SHA512 61c7fe3980510a7dbd85f4c246e7e42a0f79d8e2aacd96a0c7a14189c5dee92292efb030ac92299474162995039073288283fee0f352cf08be6975a2c86703e7
diff --git a/games-puzzle/fish-fillets/fish-fillets-1.0.1-r1.ebuild b/games-puzzle/fish-fillets/fish-fillets-1.0.1-r1.ebuild
new file mode 100644
index 00000000..3e1eb588
--- /dev/null
+++ b/games-puzzle/fish-fillets/fish-fillets-1.0.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DATA_PV="1.0.0"
+DESCRIPTION="Underwater puzzle game - find a safe way out"
+HOMEPAGE="http://fillets.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fillets/fillets-ng-${PV}.tar.gz
+ mirror://sourceforge/fillets/fillets-ng-data-${DATA_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua-slotted"
+
+RDEPEND="
+ >=media-libs/libsdl-1.2[sound,video]
+ >=media-libs/sdl-mixer-1.2.5[vorbis]
+ >=media-libs/sdl-image-1.2.2[png]
+ media-libs/smpeg
+ x11-libs/libX11
+ media-libs/sdl-ttf
+ dev-libs/fribidi
+ lua-slotted? ( dev-lang/lua:5.1= )
+ !lua-slotted? ( dev-lang/lua:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/fillets-ng-${PV}"
+
+src_prepare() {
+ default
+ #.mod was renamed to .fmod in lua 5.1.3 - bug #223271
+ sed -i \
+ -e 's/\.mod(/.fmod(/' \
+ $(grep -rl "\.mod\>" "${WORKDIR}"/fillets-ng-data-${DATA_PV}) \
+ || die "sed failed"
+ rm -f missing
+ mv configure.in configure.ac || die
+ if use lua-slotted; then
+ sed -i \
+ -e 's/LUAPFX=/LUAPFX=1/g' \
+ -e "s'-I.LUAPFX'-I${EROOT}/usr/include/lua5.1'" \
+ -e "s'-L.LUAPFX[^\"]*'-llua5.1'" \
+ configure.ac || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf --datadir="/usr/share/${PN}"
+}
+
+src_install() {
+ default
+ insinto "/usr/share/${PN}"
+ cd "${WORKDIR}"/fillets-ng-data-${DATA_PV} || die
+ rm -f COPYING
+ einstalldocs
+ doins -r *
+ newicon images/icon.png ${PN}.png
+ make_desktop_entry fillets "Fish Fillets NG"
+}
diff --git a/games-puzzle/fish-fillets/metadata.xml b/games-puzzle/fish-fillets/metadata.xml
new file mode 100644
index 00000000..40034dc8
--- /dev/null
+++ b/games-puzzle/fish-fillets/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>maintainer for USE=lua-slotted</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">fillets</remote-id>
+ </upstream>
+ <use>
+ <flag name="lua-slotted">Support slotted lua version</flag>
+ </use>
+</pkgmetadata>