summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pqiv/pqiv-2.8.3.ebuild')
-rw-r--r--media-gfx/pqiv/pqiv-2.8.3.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/media-gfx/pqiv/pqiv-2.8.3.ebuild b/media-gfx/pqiv/pqiv-2.8.3.ebuild
new file mode 100644
index 00000000..95b9f89b
--- /dev/null
+++ b/media-gfx/pqiv/pqiv-2.8.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info toolchain-funcs fdo-mime
+
+SRC_URI="https://github.com/phillipberndt/pqiv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="powerful GTK based command-line image viewer with a minimal UI"
+HOMEPAGE="https://github.com/phillipberndt/pqiv http://www.pberndt.com/Programme/Linux/pqiv/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="archive ffmpeg gtk2 imagemagick kernel_linux libav pdf postscript"
+
+RDEPEND="
+ >=dev-libs/glib-2.8:2
+ >=x11-libs/cairo-1.6
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )
+ archive? ( app-arch/libarchive:0= )
+ ffmpeg? (
+ !libav? ( media-video/ffmpeg:0= )
+ libav? ( media-video/libav:0= )
+ )
+ imagemagick? ( media-gfx/imagemagick:0= )
+ pdf? ( app-text/poppler:0= )
+ postscript? ( app-text/libspectre:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local backends="gdkpixbuf" gtkver=3
+ ! use gtk2 || gtkver=2
+ use archive && backends="${backends},archive,archive_cbx"
+ use ffmpeg || use libav && backends="${backends},libav"
+ use imagemagick && backends="${backends},wand"
+ use pdf && backends="${backends},poppler"
+ use postscript && backends="${backends},spectre"
+
+ ./configure \
+ --gtk-version=${gtkver} \
+ --backends-build=shared \
+ --backends=${backends} \
+ --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --destdir="${ED}" \
+ || die
+}
+
+src_compile() {
+ tc-export CC
+ emake VERBOSE=1 CFLAGS="${CFLAGS}"
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}