summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pqiv')
-rw-r--r--media-gfx/pqiv/Manifest1
-rw-r--r--media-gfx/pqiv/pqiv-2.6.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/pqiv/Manifest b/media-gfx/pqiv/Manifest
index 360c2b7e..338ed42d 100644
--- a/media-gfx/pqiv/Manifest
+++ b/media-gfx/pqiv/Manifest
@@ -1 +1,2 @@
DIST pqiv-2.2.tar.gz 52414 SHA256 88d625de4437c8e65a49d74e993df5debf224ecf726365e138bf90a602b8b74b
+DIST pqiv-2.6.tar.gz 96050 SHA256 f0c0d803724cdde2ccac1dc8d7e8928bdc633e758914a67320734a6961ee099c
diff --git a/media-gfx/pqiv/pqiv-2.6.ebuild b/media-gfx/pqiv/pqiv-2.6.ebuild
new file mode 100644
index 00000000..ff2c65bf
--- /dev/null
+++ b/media-gfx/pqiv/pqiv-2.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Modern rewrite of Quick Image Viewer"
+HOMEPAGE="https://github.com/phillipberndt/pqiv http://www.pberndt.com/Programme/Linux/pqiv/"
+SRC_URI="https://github.com/phillipberndt/pqiv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ffmpeg gtk2 imagemagick kernel_linux libav pdf postscript"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ >=x11-libs/cairo-1.6
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )
+ ffmpeg? (
+ !libav? ( media-video/ffmpeg:0= )
+ libav? ( media-video/libav:0= )
+ )
+ imagemagick? ( media-gfx/imagemagick:0= )
+ pdf? ( app-text/poppler:0= )
+ postscript? ( app-text/libspectre:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( "README.markdown" )
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:/lib/:/$(get_libdir)/:g" \
+ GNUmakefile || die
+}
+
+src_configure() {
+ local backends="gdkpixbuf" gtkver=3
+ ! use gtk2 || gtkver=2
+ use ffmpeg || use libav && backends="${backends},libav"
+ use imagemagick && backends="${backends},wand"
+ use pdf && backends="${backends},poppler"
+ use postscript && backends="${backends},spectre"
+
+ ./configure \
+ --gtk-version=${gtkver} \
+ --backends-build=shared \
+ --backends=${backends} \
+ --prefix="${EPREFIX}/usr" \
+ --destdir="${ED}" \
+ || die
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+ dodoc README.markdown
+}