summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/sundtek-tv/sundtek-tv-151010.162411-r1.ebuild')
-rw-r--r--media-tv/sundtek-tv/sundtek-tv-151010.162411-r1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-tv/sundtek-tv/sundtek-tv-151010.162411-r1.ebuild b/media-tv/sundtek-tv/sundtek-tv-151010.162411-r1.ebuild
index 26d24798..53f227d6 100644
--- a/media-tv/sundtek-tv/sundtek-tv-151010.162411-r1.ebuild
+++ b/media-tv/sundtek-tv/sundtek-tv-151010.162411-r1.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit eutils linux-info pax-utils readme.gentoo systemd unpacker
+EAPI=6
+inherit linux-info pax-utils readme.gentoo systemd unpacker
# The following variable is only for testing purposes. Leave it to "false"
keep_original=false
@@ -28,7 +28,9 @@ DOC_CONTENTS="To initialize sundtek drivers during booting call
You will probably need to adapt sundtek-local.service to your defaults
"
-QA_PREBUILT="opt/bin/* opt/bin/*/* usr/$(get_libdir)/* usr/share/doc/*/*/*"
+pkg_setup() {
+ QA_PREBUILT="opt/bin/* opt/bin/*/* usr/$(get_libdir)/* usr/share/doc/*/*/*"
+}
src_unpack() {
local subdir a
@@ -141,7 +143,7 @@ want to use with sundtek-tv.
"
ln -sfn mediaclient.video mediaclient.audio
ln -sfn mediaclient.video mediaclient.dvb
- epatch_user
+ eapply_user
}
src_install() {
@@ -187,4 +189,5 @@ pkg_postinst() {
else elog "You need to set LD_PRELOAD locally, see /usr/share/doc/${PF}/README.gentoo*"
fi
fi
+ readme.gentoo_print_elog
}