summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/w_scan/Manifest1
-rw-r--r--media-tv/w_scan/metadata.xml7
-rw-r--r--media-tv/w_scan/w_scan-20170107.ebuild31
3 files changed, 39 insertions, 0 deletions
diff --git a/media-tv/w_scan/Manifest b/media-tv/w_scan/Manifest
new file mode 100644
index 00000000..bdd03f11
--- /dev/null
+++ b/media-tv/w_scan/Manifest
@@ -0,0 +1 @@
+DIST w_scan-20170107.tar.bz2 245517 SHA256 38e0f38a7bf06cff6d6ea01652ad4ee60da2cb0e937360468f936da785b46ffe SHA512 c8e163b5e4897e2bc48596a1104974c79807432c423a3dd172e85c6ed6d4f9a4a471150ae7fe1b78fe570987e9fdee666a491700368c8499b03e9b13aa5cde6a
diff --git a/media-tv/w_scan/metadata.xml b/media-tv/w_scan/metadata.xml
new file mode 100644
index 00000000..49fd40c5
--- /dev/null
+++ b/media-tv/w_scan/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hd_brummy@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-tv/w_scan/w_scan-20170107.ebuild b/media-tv/w_scan/w_scan-20170107.ebuild
new file mode 100644
index 00000000..f453db0d
--- /dev/null
+++ b/media-tv/w_scan/w_scan-20170107.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Scan for DVB-C/DVB-T/DVB-S channels without prior knowledge of frequencies and modulations"
+HOMEPAGE="http://wirbel.htpc-forum.de/w_scan/index2.html"
+SRC_URI="http://wirbel.htpc-forum.de/w_scan/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=">=virtual/linuxtv-dvb-headers-5.8"
+RDEPEND=""
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ dodoc ChangeLog README
+
+ if use doc; then
+ dodoc doc/README.file_formats doc/README_VLC_DVB
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/rotor.conf
+ fi
+}