summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/martian/ChangeLog4
-rw-r--r--net-dialup/martian/Manifest5
-rw-r--r--net-dialup/martian/files/grsecurity.patch15
-rw-r--r--net-dialup/martian/martian-20080625.ebuild6
4 files changed, 27 insertions, 3 deletions
diff --git a/net-dialup/martian/ChangeLog b/net-dialup/martian/ChangeLog
index 76e7b117..38d32d3e 100644
--- a/net-dialup/martian/ChangeLog
+++ b/net-dialup/martian/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 26 Aug 2011; Martin Väth <martin@mvath.de>
+ Force sublevel to fix broken version number test for >=linux-3.0
+ Fix breakage of grsecurity
+
03 Jan 2011; Martin Väth <martin@mvath.de>
Bump to EAPI=4.
diff --git a/net-dialup/martian/Manifest b/net-dialup/martian/Manifest
index 916bb7f0..0c5189ea 100644
--- a/net-dialup/martian/Manifest
+++ b/net-dialup/martian/Manifest
@@ -1,4 +1,5 @@
+AUX grsecurity.patch 239 RMD160 161fdb67c7d50e8670802617e8a608b8661f3fa1 SHA1 1af0afabd9dcb0dbe6e577fcc2de2e3ecb7244a8 SHA256 bdee550ba3bb0782532fa0a8cf079f62c735dd1ee4f5c29f7995152dc3aa2a54
DIST martian-full-20080625.tar.gz 274510 RMD160 8110832e140d21e58ee5a6149f8143f8bf063821 SHA1 bc3bae2fe5a7519e37645be787ec45b313044150 SHA256 66761d2735bc59252e26535f08f9c7f4fa9bc5475d799fa06fc1781ab115cd91
-EBUILD martian-20080625.ebuild 1638 RMD160 826fb68665e41c3221ab4dc5b6464c830d352a95 SHA1 7bd8c85014294e2b88b9950423fb6e90fcfdc6da SHA256 61f5ed67f3d1e6e9f73b8f9694932be346b4b443236e09aa9f519576203746e0
-MISC ChangeLog 362 RMD160 4fef4801bc6058a216329c4fc41502d86a996e42 SHA1 5af4d108f2f1b6f2564ab599753d20ef26e9a473 SHA256 3a5836601d949a38ef76422a250126662f1e4691b9d157d65053ba9410b31585
+EBUILD martian-20080625.ebuild 1687 RMD160 10c9d78759876f6d11a4e4e4af75639fa097e0cc SHA1 1aea54cceeab1a5227274c07b32b96866dfabdae SHA256 f7d97c2f2262151be483780bc44f9ddafeaaf92467f5ef19815fe1d918f0b921
+MISC ChangeLog 523 RMD160 7a4aafeb9cd2facb67f207083396cd70463e34bf SHA1 5fa090132559e6bf70589d352205f7a4513d950d SHA256 69c0ba53b26ac5a24aeb465d5c2c56a5a2e5ce6c5534e6e20050cc39c054262b
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/net-dialup/martian/files/grsecurity.patch b/net-dialup/martian/files/grsecurity.patch
new file mode 100644
index 00000000..332680d9
--- /dev/null
+++ b/net-dialup/martian/files/grsecurity.patch
@@ -0,0 +1,15 @@
+--- kmodule/mfifo.h
++++ kmodule/mfifo.h
+@@ -20,7 +20,11 @@
+
+ void (*wrap) (mfifo_t *fifo, int *ending);
+ int (*space) (mfifo_t *fifo);
+-};
++}
++#ifdef __no_const
++__no_const
++#endif
++;
+
+ struct _mfifo {
+ /* struct circ_buf header; */
diff --git a/net-dialup/martian/martian-20080625.ebuild b/net-dialup/martian/martian-20080625.ebuild
index d660c238..9621cfe7 100644
--- a/net-dialup/martian/martian-20080625.ebuild
+++ b/net-dialup/martian/martian-20080625.ebuild
@@ -34,7 +34,11 @@ pkg_setup() {
fi
BUILD_TARGETS="all"
- BUILD_PARAMS="KERNEL_DIR='${KV_DIR}' SUBLEVEL='${KV_PATCH}'"
+ BUILD_PARAMS="KERNEL_DIR='${KV_DIR}' SUBLEVEL='21'"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/grsecurity.patch"
}
src_install() {