summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/firewall-mv/firewall-mv-7.1.ebuild')
-rw-r--r--net-firewall/firewall-mv/firewall-mv-7.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-firewall/firewall-mv/firewall-mv-7.1.ebuild b/net-firewall/firewall-mv/firewall-mv-7.1.ebuild
new file mode 100644
index 00000000..97d60bc3
--- /dev/null
+++ b/net-firewall/firewall-mv/firewall-mv-7.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils systemd vcs-snapshot
+
+DESCRIPTION="Initialize iptables and net-related sysctl variables"
+HOMEPAGE="https://github.com/vaeth/firewall-mv/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-shells/push"
+DEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "s!/etc/!${EPREFIX}/etc/!g" \
+ -e "s!/usr/!${EPREFIX}/usr/!g" \
+ firewall \
+ firewall.config \
+ systemd/*
+ epatch_user
+}
+
+src_install() {
+ into /
+ dosbin firewall sysctl.net
+ insinto /etc
+ doins firewall.config
+ insinto /usr/lib/modules-load.d
+ doins modules-load.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ doconfd openrc/conf.d/*
+ doinitd openrc/init.d/*
+ dodoc README
+ systemd_dounit systemd/*
+}