summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/netctl/Manifest1
-rw-r--r--net-misc/netctl/metadata.xml5
-rw-r--r--net-misc/netctl/netctl-1.11.ebuild63
3 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/netctl/Manifest b/net-misc/netctl/Manifest
new file mode 100644
index 00000000..b4bbb75b
--- /dev/null
+++ b/net-misc/netctl/Manifest
@@ -0,0 +1 @@
+DIST netctl-1.11.tar.xz 43868 SHA512 00bf4b016d755796980d492305332230a2089e843bf0921a7fd28ef17400e024bac0987a08c4caadf1c19becae73ce7f33d1e51ce1ea9f47e0129e1aff1ccd71
diff --git a/net-misc/netctl/metadata.xml b/net-misc/netctl/metadata.xml
new file mode 100644
index 00000000..7a38bb90
--- /dev/null
+++ b/net-misc/netctl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/net-misc/netctl/netctl-1.11.ebuild b/net-misc/netctl/netctl-1.11.ebuild
new file mode 100644
index 00000000..9c9c5a21
--- /dev/null
+++ b/net-misc/netctl/netctl-1.11.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 eutils
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
+ inherit git-2
+ DEPEND="app-text/asciidoc"
+else
+ SRC_URI="https://sources.archlinux.org/other/packages/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Profile based network connection tool from Arch Linux"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
+ https://www.archlinux.org/packages/core/any/netctl/
+ https://projects.archlinux.org/netctl.git/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND+="
+ virtual/pkgconfig
+ sys-apps/systemd
+"
+RDEPEND="
+ >=app-shells/bash-4.0
+ >=net-dns/openresolv-3.5.4-r1
+ sys-apps/iproute2
+ sys-apps/systemd
+ !<net-misc/dhcpcd-6.4.0
+"
+
+src_prepare() {
+ sed -i -e "s:/usr/bin/ifplugd:/usr/sbin/ifplugd:" \
+ "services/netctl-ifplugd@.service" || die
+ default
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" SHELL=bash install
+ dodoc AUTHORS NEWS README
+ newbashcomp contrib/bash-completion netctl
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _netctl
+}
+
+pkg_postinst() {
+ optfeature "DHCP support" net-misc/dhcpcd ">=net-misc/dhcp-5.6.7[client]"
+ optfeature "WPA support" net-wireless/wpa_supplicant
+ optfeature "interactive assistant" dev-util/dialog
+ optfeature "automatic connection" sys-apps/ifplugd
+ optfeature "bonding support" net-misc/ifenslave
+ optfeature "dialup support" net-dialup/ppp
+}