summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cpi/cpi-2.11.ebuild')
-rw-r--r--sys-apps/cpi/cpi-2.11.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/cpi/cpi-2.11.ebuild b/sys-apps/cpi/cpi-2.11.ebuild
new file mode 100644
index 00000000..bd33c28f
--- /dev/null
+++ b/sys-apps/cpi/cpi-2.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+RESTRICT="mirror"
+
+DESCRIPTION="A wrapper for cp -i -a, making use of diff"
+HOMEPAGE="https://github.com/vaeth/cpi/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- bin/cpi || die
+ eapply_user
+}
+
+src_install() {
+ dobin bin/cpi
+ insinto /usr/bin
+ doins bin/mvi
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}