summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cpi')
-rw-r--r--sys-apps/cpi/Manifest1
-rw-r--r--sys-apps/cpi/cpi-2.10.ebuild31
-rw-r--r--sys-apps/cpi/metadata.xml16
3 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/cpi/Manifest b/sys-apps/cpi/Manifest
new file mode 100644
index 00000000..50552014
--- /dev/null
+++ b/sys-apps/cpi/Manifest
@@ -0,0 +1 @@
+DIST cpi-2.10.tar.gz 3416 SHA256 67d6ea00b9817c1da523158ea61ed4441683343b9df83babdf1b707ac7d6d35f SHA512 19e6c6aa297e7ebba73eddfe1eb1d78252756eda39ac34b82557747c78789d0503e824d9e2902e42d63c1bea1c49becf02ad5c6b7c4fd4737a29e6708a2f4633 WHIRLPOOL 9592f1bab4a3a516a3e94e45c60a80046e963f47347099820f8a5a5649e207e403780b712eeb613be9d2dadbee15b781f35ce7c2f39ef6b393866ef62decc7cf
diff --git a/sys-apps/cpi/cpi-2.10.ebuild b/sys-apps/cpi/cpi-2.10.ebuild
new file mode 100644
index 00000000..736a1051
--- /dev/null
+++ b/sys-apps/cpi/cpi-2.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="A wrapper for cp -i -a, making use of diff"
+HOMEPAGE="https://github.com/vaeth/cpi/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- bin/cpi || die
+ epatch_user
+}
+
+src_install() {
+ dobin bin/cpi
+ insinto /usr/bin
+ doins bin/mvi
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}
diff --git a/sys-apps/cpi/metadata.xml b/sys-apps/cpi/metadata.xml
new file mode 100644
index 00000000..4b3260b1
--- /dev/null
+++ b/sys-apps/cpi/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/cpi</remote-id>
+ </upstream>
+</pkgmetadata>