summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/openrc-wrapper/openrc-wrapper-2.00.ebuild')
-rw-r--r--sys-apps/openrc-wrapper/openrc-wrapper-2.00.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/openrc-wrapper/openrc-wrapper-2.00.ebuild b/sys-apps/openrc-wrapper/openrc-wrapper-2.00.ebuild
new file mode 100644
index 00000000..37f0dc36
--- /dev/null
+++ b/sys-apps/openrc-wrapper/openrc-wrapper-2.00.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit systemd
+
+DESCRIPTION="Use openrc init scripts with systemd or other init systems"
+HOMEPAGE="https://github.com/vaeth/openrc-wrapper"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="!!<sys-fs/squash_dir-3.2"
+# the last dependency is not really needed, but without it the output is ugly,
+# and the costs are really not high: sys-apps/gentoo-functions is tiny
+RDEPEND="${DEPEND}
+|| ( sys-apps/gentoo-functions sys-apps/openrc )"
+IUSE=""
+
+src_install() {
+ dodoc README
+ dobin bin/*
+ systemd_dounit systemd/system/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}