summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/starter/starter-2.15.ebuild')
-rw-r--r--sys-apps/starter/starter-2.15.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/starter/starter-2.15.ebuild b/sys-apps/starter/starter-2.15.ebuild
new file mode 100644
index 00000000..eeeae225
--- /dev/null
+++ b/sys-apps/starter/starter-2.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="POSIX shell script and function to schedule commands"
+HOMEPAGE="https://github.com/vaeth/starter/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-shells/push
+ >=app-shells/runtitle-2.3"
+DEPEND=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- bin/* || die
+ epatch_user
+}
+
+src_install() {
+ local i
+ insinto /usr/bin
+ for i in bin/*
+ do if test -h "${i}" || ! test -x "${i}"
+ then doins "${i}"
+ else dobin "${i}"
+ fi
+ done
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ dodoc README
+}