summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/cpi/cpi-2.10.ebuild5
-rw-r--r--sys-apps/less/less-481.ebuild10
-rw-r--r--sys-apps/lesspipe/lesspipe-1.83.ebuild6
-rw-r--r--sys-apps/starter/starter-2.15.ebuild5
4 files changed, 10 insertions, 16 deletions
diff --git a/sys-apps/cpi/cpi-2.10.ebuild b/sys-apps/cpi/cpi-2.10.ebuild
index 736a1051..e951bc0e 100644
--- a/sys-apps/cpi/cpi-2.10.ebuild
+++ b/sys-apps/cpi/cpi-2.10.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
RESTRICT="mirror"
-inherit eutils
DESCRIPTION="A wrapper for cp -i -a, making use of diff"
HOMEPAGE="https://github.com/vaeth/cpi/"
@@ -19,7 +18,7 @@ src_prepare() {
use prefix || sed -i \
-e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
-- bin/cpi || die
- epatch_user
+ eapply_user
}
src_install() {
diff --git a/sys-apps/less/less-481.ebuild b/sys-apps/less/less-481.ebuild
index ddbb26ff..016751e2 100644
--- a/sys-apps/less/less-481.ebuild
+++ b/sys-apps/less/less-481.ebuild
@@ -2,9 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-
-inherit eutils
+EAPI=6
CODE2COLOR_PV="0.2"
CODE2COLOR_P="code2color-${CODE2COLOR_PV}"
@@ -50,14 +48,14 @@ src_unpack() {
src_prepare() {
if use less-select
- then epatch "${SELECTDIR}/patches/less-${PATCHVER}-select.patch" || die
+ then eapply "${SELECTDIR}/patches/less-${PATCHVER}-select.patch"
"${SELECTDIR}"/after-patch || die "${SELECTDIR}/after-patch failed"
sed -i -e 's|\([^a-zA-Z]\)/etc/less-select-key.bin|\1'"${EPREFIX}"'/etc/less/select-key.bin|g' \
"${SELECTDIR}/bin/less-select" || die
fi
- epatch "${FILESDIR}/${CODE2COLOR_P}.patch"
+ eapply -p0 "${FILESDIR}/${CODE2COLOR_P}.patch"
chmod a+x configure || die
- epatch_user
+ eapply_user
}
src_configure() {
diff --git a/sys-apps/lesspipe/lesspipe-1.83.ebuild b/sys-apps/lesspipe/lesspipe-1.83.ebuild
index be9849e0..4826407d 100644
--- a/sys-apps/lesspipe/lesspipe-1.83.ebuild
+++ b/sys-apps/lesspipe/lesspipe-1.83.ebuild
@@ -2,11 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
RESTRICT="mirror"
-inherit eutils
-
DESCRIPTION="Wolfgang Friebel's preprocessor for sys-apps/less. Append colon to filename to disable"
HOMEPAGE="http://www-zeuthen.desy.de/~friebel/unix/lesspipe.html"
SRC_URI="http://www-zeuthen.desy.de/~friebel/unix/less/${P}.tar.gz"
@@ -197,7 +195,7 @@ src_prepare() {
use netcdf; ModifyX 'ncdump'
ModifyEnd
printf '%s\n' 'LESS_ADVANCED_PREPROCESSOR=1' >70lesspipe
- epatch_user
+ eapply_user
}
src_configure() {
diff --git a/sys-apps/starter/starter-2.15.ebuild b/sys-apps/starter/starter-2.15.ebuild
index eeeae225..8b6bc8eb 100644
--- a/sys-apps/starter/starter-2.15.ebuild
+++ b/sys-apps/starter/starter-2.15.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
RESTRICT="mirror"
-inherit eutils
DESCRIPTION="POSIX shell script and function to schedule commands"
HOMEPAGE="https://github.com/vaeth/starter/"
@@ -22,7 +21,7 @@ src_prepare() {
use prefix || sed -i \
-e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
-- bin/* || die
- epatch_user
+ eapply_user
}
src_install() {