summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/aufs-util/aufs-util-99999999.3.ebuild')
-rw-r--r--sys-fs/aufs-util/aufs-util-99999999.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-fs/aufs-util/aufs-util-99999999.3.ebuild b/sys-fs/aufs-util/aufs-util-99999999.3.ebuild
new file mode 100644
index 00000000..bddc41c5
--- /dev/null
+++ b/sys-fs/aufs-util/aufs-util-99999999.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="4"
+EGIT_REPO_URI="git://aufs.git.sourceforge.net/gitroot/aufs/aufs-util.git"
+EGIT_PROJECT="aufs-util"
+EGIT_BRANCH="aufs3.0"
+EGIT_COMMIT="${EGIT_BRANCH}"
+[ -n "${EGIT_OFFLINE:-${ESCM_OFFLINE}}" ] || EGIT_PRUNE=true
+EGIT_HAS_SUBMODULES=true
+inherit git linux-info multilib
+
+DESCRIPTION="Userspace tools for aufs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Since this is a live ebuild, we require ACCEPT_KEYWORDS='**'
+#KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
+IUSE=""
+PROPERTIES="live"
+
+RDEPEND=""
+DEPEND="dev-vcs/git[curl]"
+
+src_prepare() {
+ local i l
+ ln -s "${KERNEL_DIR}"/include local_kernel
+ set -- local_kernel/linux/aufs*.h
+ test -e "${1}" || {
+ eerror "It seems you do not have installed aufs into your kernel tree."
+ die "You might need to emerge >=sys-fs/aufs-99999999::mv"
+ }
+ l="s|/usr/lib|$(get_libdir)|"
+ sed -i -e "1iCFLAGS += -I./local_kernel" -e "${l}" Makefile || \
+ die "Patching Makefile failed"
+ for i in lib*/Makefile
+ do test -e "${i}" || continue
+ sed -i -e "1iCFLAGS += -I../local_kernel" -e "${l}" "${i}" || \
+ die "Patching ${i} failed"
+ done
+}