summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild
index 938134c1..5f4b79fd 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header $
+EAPI="3"
+
inherit toolchain-funcs eutils
MY_PV=${PV}
@@ -18,9 +20,7 @@ RDEPEND="sys-libs/zlib"
S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e 's:-O2:$(CFLAGS):' \
-e '/-lz/s:$: $(LDFLAGS):' \