summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild
deleted file mode 100644
index a88f887e..00000000
--- a/sys-fs/squashfs-tools/squashfs-tools-4.0-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header $
-
-EAPI="4"
-inherit toolchain-funcs eutils
-
-MY_PV=${PV}
-DESCRIPTION="Tool for creating compressed filesystem type squashfs"
-HOMEPAGE="http://squashfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="+progress-redirect"
-
-RDEPEND="sys-libs/zlib"
-
-S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
-
-src_prepare() {
- sed -i \
- -e 's:-O2:$(CFLAGS):' \
- -e '/-lz/s:$: $(LDFLAGS):' \
- Makefile || die "sed failed"
- use progress-redirect && \
- epatch "${FILESDIR}/${P}-progress-stderr.patch"
- sed -i -e 's:get_nprocs():sysconf(_SC_NPROCESSORS_ONLN):' *.c
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" || die
-}
-
-src_install() {
- dobin mksquashfs unsquashfs || die
- cd ..
- dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README
-}
-
-pkg_postinst() {
- ewarn "This version of mksquashfs requires a 2.6.29 kernel or better."
-}