summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild')
-rw-r--r--sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild b/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild
new file mode 100644
index 00000000..1813a692
--- /dev/null
+++ b/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild
@@ -0,0 +1,35 @@
+ # Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A script for checking the hardening options in the Linux kernel config"
+HOMEPAGE="https://github.com/a13xp0p0v/kconfig-hardened-check"
+
+case ${PV} in
+99999999)
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/a13xp0p0v/kconfig-hardened-check"
+;;
+*)
+ SRC_URI="https://github.com/a13xp0p0v/kconfig-hardened-check/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RESTRICT="mirror"
+;;
+esac
+
+IUSE=""
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r "${PN//-/_}"/config_files/ README.md
+}