summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/kernel/kernel-4.6.ebuild')
-rw-r--r--sys-kernel/kernel/kernel-4.6.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-kernel/kernel/kernel-4.6.ebuild b/sys-kernel/kernel/kernel-4.6.ebuild
new file mode 100644
index 00000000..b41b5281
--- /dev/null
+++ b/sys-kernel/kernel/kernel-4.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2011-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="A POSIX shell script to compile the kernel with user permissions"
+HOMEPAGE="https://github.com/vaeth/kernel/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# This should really depend on a USE-flag but must not by policy.
+# Waiting for https://bugs.gentoo.org/show_bug.cgi?id=424283
+OPTIONAL_RDEPEND=">=app-shells/runtitle-2.3"
+
+RDEPEND="app-admin/sudo
+ app-admin/sudox
+ >=app-shells/push-2.0-r2
+ !<dev-util/ccache-3.2
+ ${OPTIONAL_RDEPEND}"
+DEPEND=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- bin/* || die
+ default
+}
+
+src_install() {
+ dobin bin/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}
+
+pkg_postinst() {
+ optfeature "faster execution" '>=app-portage/eix-0.32.2'
+}