summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/Manifest4
-rw-r--r--x11-libs/gtk+/gtk+-2.24.32.ebuild (renamed from x11-libs/gtk+/gtk+-2.24.31-r1.ebuild)34
-rw-r--r--x11-libs/gtk+/gtk+-3.22.19.ebuild235
3 files changed, 19 insertions, 254 deletions
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index 1c939c8d..5f78cca4 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,3 +1,3 @@
-DIST gtk+-2.24.31.tar.xz 12805344 SHA512 75b846661308d94b5236e7e1c367deabf57753792ca87e92f9769822dd5ec90e00cd8d5574adcc12162e3702e1ae6dc152278a1d218f9bd9e4d1c8dc1dd520c1
-DIST gtk+-3.22.19.tar.xz 18841024 SHA512 c83198794433ee6eb29f8740d59bd7056cd36808b4bff1a99563ab1a1742e6635dab4f2a8be33317f74d3b336f0d1adc28dd91410da056b50a08c215f184dce2
+DIST gtk+-2.24.32-patchset.tar.xz 6392 SHA512 6c8763826b479c9c122bb991ae42b0ce0e754d460be5c6ea8d1bba28f7318c014822eccaae0b39c3b7c16804991c8c46c53cd8ded3ad6212830a2f5746567543
+DIST gtk+-2.24.32.tar.xz 12620860 SHA512 8e8fd9ae32f1d6fb544da260f00599f0f05090d910d767b06ef086ab4f1f8373a29bb0da9767761c9b5f4cfd51b5c45d0fa5d39b0428c839ddf0a579df806696
DIST gtk+-3.22.30.tar.xz 18946084 SHA512 31440a615cb2f406d0f904e59febb8f876106f27818ddd6951c76ab9bcb421ca480dae2bebfb1c4b1e03b833fc7c42e9feede053d9d71f19a02fe778e3197b38
diff --git a/x11-libs/gtk+/gtk+-2.24.31-r1.ebuild b/x11-libs/gtk+/gtk+-2.24.32.ebuild
index 0aaafae4..93f891f5 100644
--- a/x11-libs/gtk+/gtk+-2.24.31-r1.ebuild
+++ b/x11-libs/gtk+/gtk+-2.24.32.ebuild
@@ -1,13 +1,15 @@
-# Copyright 2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
GNOME2_LA_PUNT="yes"
+GNOME2_EAUTORECONF="yes"
-inherit autotools eutils flag-o-matic gnome2 multilib multilib-minimal readme.gentoo-r1 virtualx
+inherit eutils flag-o-matic gnome2 multilib multilib-minimal readme.gentoo-r1 virtualx
DESCRIPTION="Gimp ToolKit +"
HOMEPAGE="https://www.gtk.org/"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz"
LICENSE="LGPL-2+"
SLOT="2"
@@ -16,13 +18,12 @@ REQUIRED_USE="
xinerama? ( !aqua )
"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
# Upstream wants us to do their job:
# https://bugzilla.gnome.org/show_bug.cgi?id=768663#c1
RESTRICT="test"
-# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
COMMON_DEPEND="
>=dev-libs/atk-2.10.0[introspection?,${MULTILIB_USEDEP}]
>=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
@@ -104,6 +105,15 @@ MULTILIB_CHOST_TOOLS=(
/usr/bin/gtk-query-immodules-2.0$(get_exeext)
)
+PATCHES=(
+ # Fix tests running when building out of sources, bug #510596, upstream bug #730319
+ "${FILESDIR}"/${PN}-2.24.24-out-of-source.patch
+ # Rely on split gtk-update-icon-cache package, bug #528810
+ "${FILESDIR}"/${PN}-2.24.31-update-icon-cache.patch # requires eautoreconf
+ # Upstream gtk-2-24 branch up to 2018-05-06 state, bug #650536 safety
+ "${WORKDIR}"/patches/ # requires eautoreconf
+)
+
strip_builddir() {
local rule=$1
shift
@@ -119,9 +129,9 @@ set_gtk2_confdir() {
}
src_prepare() {
- # marshalers code was pre-generated with glib-2.31, upstream bug #662109
- rm -v gdk/gdkmarshalers.c gtk/gtkmarshal.c gtk/gtkmarshalers.c \
- perf/marshalers.c || die
+ # Various glib marshaller churn could break build against a different glib version, force regeneration
+ rm -v gdk/gdkmarshalers.{c,h} gtk/gtkmarshal.{c,h} gtk/gtkmarshalers.{c,h} \
+ perf/marshalers.{c,h} gtk/gtkaliasdef.c gtk/gtkalias.h || die
# Stop trying to build unmaintained docs, bug #349754, upstream bug #623150
strip_builddir SUBDIRS tutorial docs/Makefile.{am,in}
@@ -169,16 +179,6 @@ src_prepare() {
strip_builddir SRC_SUBDIRS demos Makefile.{am,in}
fi
- # Fix tests running when building out of sources, bug #510596, upstream bug #730319
- eapply "${FILESDIR}"/${PN}-2.24.24-out-of-source.patch
-
- # Rely on split gtk-update-icon-cache package, bug #528810
- eapply "${FILESDIR}"/${PN}-2.24.31-update-icon-cache.patch
-
- # Fix beep when overwriting at the end of a gtkentry, from gtk-2-24 branch
- eapply "${FILESDIR}"/${PN}-2.24.31-fix-gtkentry-beep.patch
-
- eautoreconf
gnome2_src_prepare
}
diff --git a/x11-libs/gtk+/gtk+-3.22.19.ebuild b/x11-libs/gtk+/gtk+-3.22.19.ebuild
deleted file mode 100644
index 01b30ee1..00000000
--- a/x11-libs/gtk+/gtk+-3.22.19.ebuild
+++ /dev/null
@@ -1,235 +0,0 @@
-# Copyright 2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-
-inherit autotools flag-o-matic gnome2 multilib virtualx multilib-minimal
-
-DESCRIPTION="Gimp ToolKit +"
-HOMEPAGE="https://www.gtk.org/"
-
-LICENSE="LGPL-2+"
-SLOT="3"
-IUSE="adwaita-icon-theme aqua atk-bridge broadway cloudprint colord cups examples +introspection test vim-syntax wayland +X xinerama"
-REQUIRED_USE="
- || ( aqua wayland X )
- xinerama? ( X )
-"
-
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-# Upstream wants us to do their job:
-# https://bugzilla.gnome.org/show_bug.cgi?id=768662#c1
-RESTRICT="test"
-
-# FIXME: introspection data is built against system installation of gtk+:3,
-# bug #????
-COMMON_DEPEND="
- >=dev-libs/atk-2.15[introspection?,${MULTILIB_USEDEP}]
- >=dev-libs/glib-2.49.4:2[${MULTILIB_USEDEP}]
- media-libs/fontconfig[${MULTILIB_USEDEP}]
- >=media-libs/libepoxy-1.0[X(+)?,${MULTILIB_USEDEP}]
- >=x11-libs/cairo-1.14[aqua?,glib,svg,X?,${MULTILIB_USEDEP}]
- >=x11-libs/gdk-pixbuf-2.30:2[introspection?,${MULTILIB_USEDEP}]
- >=x11-libs/pango-1.37.3[introspection?,${MULTILIB_USEDEP}]
- x11-misc/shared-mime-info
-
- cloudprint? (
- >=net-libs/rest-0.7[${MULTILIB_USEDEP}]
- >=dev-libs/json-glib-1.0[${MULTILIB_USEDEP}] )
- colord? ( >=x11-misc/colord-0.1.9:0=[${MULTILIB_USEDEP}] )
- cups? ( >=net-print/cups-1.2[${MULTILIB_USEDEP}] )
- introspection? ( >=dev-libs/gobject-introspection-1.39:= )
- wayland? (
- >=dev-libs/wayland-1.9.91[${MULTILIB_USEDEP}]
- >=dev-libs/wayland-protocols-1.9
- media-libs/mesa[wayland,${MULTILIB_USEDEP}]
- >=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
- )
- X? (
- atk-bridge? ( >=app-accessibility/at-spi2-atk-2.5.3[${MULTILIB_USEDEP}] )
- x11-libs/libX11[${MULTILIB_USEDEP}]
- >=x11-libs/libXi-1.3[${MULTILIB_USEDEP}]
- x11-libs/libXext[${MULTILIB_USEDEP}]
- >=x11-libs/libXrandr-1.5[${MULTILIB_USEDEP}]
- x11-libs/libXcursor[${MULTILIB_USEDEP}]
- x11-libs/libXfixes[${MULTILIB_USEDEP}]
- x11-libs/libXcomposite[${MULTILIB_USEDEP}]
- x11-libs/libXdamage[${MULTILIB_USEDEP}]
- xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
- )
-"
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xsl-stylesheets
- app-text/docbook-xml-dtd:4.1.2
- dev-libs/libxslt
- dev-libs/gobject-introspection-common
- >=dev-util/gdbus-codegen-2.48
- >=dev-util/gtk-doc-am-1.20
- >=sys-devel/gettext-0.19.7[${MULTILIB_USEDEP}]
- virtual/pkgconfig[${MULTILIB_USEDEP}]
- X? (
- x11-proto/xextproto[${MULTILIB_USEDEP}]
- x11-proto/xproto[${MULTILIB_USEDEP}]
- x11-proto/inputproto[${MULTILIB_USEDEP}]
- x11-proto/damageproto[${MULTILIB_USEDEP}]
- xinerama? ( x11-proto/xineramaproto[${MULTILIB_USEDEP}] )
- )
- test? (
- media-fonts/font-misc-misc
- media-fonts/font-cursor-misc )
-"
-# gtk+-3.2.2 breaks Alt key handling in <=x11-libs/vte-0.30.1:2.90
-# gtk+-3.3.18 breaks scrolling in <=x11-libs/vte-0.31.0:2.90
-RDEPEND="${COMMON_DEPEND}
- >=dev-util/gtk-update-icon-cache-3
- !<gnome-base/gail-1000
- !<x11-libs/vte-0.31.0:2.90
-"
-# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
-PDEPEND="
- adwaita-icon-theme? ( gnome-base/librsvg[${MULTILIB_USEDEP}]
- >=x11-themes/adwaita-icon-theme-3.14 )
- !adwaita-icon-theme? ( x11-themes/hicolor-icon-theme virtual/freedesktop-icon-theme )
- vim-syntax? ( app-vim/gtk-syntax )
-"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/gtk-query-immodules-3.0$(get_exeext)
-)
-
-strip_builddir() {
- local rule=$1
- shift
- local directory=$1
- shift
- sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
- || die "Could not strip director ${directory} from build."
-}
-
-src_prepare() {
- if ! use test ; then
- # don't waste time building tests
- strip_builddir SRC_SUBDIRS testsuite Makefile.{am,in}
-
- # the tests dir needs to be build now because since commit
- # 7ff3c6df80185e165e3bf6aa31bd014d1f8bf224 tests/gtkgears.o needs to be there
- # strip_builddir SRC_SUBDIRS tests Makefile.{am,in}
- fi
-
- if ! use examples; then
- # don't waste time building demos
- strip_builddir SRC_SUBDIRS demos Makefile.{am,in}
- strip_builddir SRC_SUBDIRS examples Makefile.{am,in}
- fi
-
- # gtk-update-icon-cache is installed by dev-util/gtk-update-icon-cache
- eapply "${FILESDIR}"/${PN}-3.22.2-update-icon-cache.patch
-
- # Use patches from BSD to make gtk3-atk-bridge a true option -
- # This was intentionally removed by upstream, see
- # https://mail.gnome.org/archives/commits-list/2012-June/msg03813.html
- eapply "${FILESDIR}"/${PN}-atk-bridge-config.ac.patch
- eapply "${FILESDIR}"/${PN}-atk-bridge-config.h.in.patch
- eapply "${FILESDIR}"/${PN}-atk-bridge-gtkaccessibility.patch
-
- eautoreconf
- gnome2_src_prepare
-}
-
-multilib_src_configure() {
- # need libdir here to avoid a double slash in a path that libtool doesn't
- # grok so well during install (// between $EPREFIX and usr ...)
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- $(use_enable aqua quartz-backend) \
- $(use_enable broadway broadway-backend) \
- $(use_enable cloudprint) \
- $(use_enable colord) \
- $(use_enable cups cups auto) \
- $(multilib_native_use_enable introspection) \
- $(use_enable wayland wayland-backend) \
- $(use_enable X x11-backend) \
- $(use_enable X xcomposite) \
- $(use_enable X xdamage) \
- $(use_enable X xfixes) \
- $(use_enable X xkb) \
- $(use_enable X xrandr) \
- $(use_enable xinerama) \
- $(use_with atk-bridge) \
- --disable-papi \
- --disable-mir-backend \
- --enable-man \
- --with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- CUPS_CONFIG="${EPREFIX}/usr/bin/${CHOST}-cups-config"
-
- # work-around gtk-doc out-of-source brokedness
- if multilib_is_native_abi; then
- local d
- for d in gdk gtk libgail-util; do
- ln -s "${S}"/docs/reference/${d}/html docs/reference/${d}/html || die
- done
- fi
-}
-
-multilib_src_test() {
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
- GSETTINGS_SCHEMA_DIR="${S}/gtk" virtx emake check
-}
-
-multilib_src_install() {
- gnome2_src_install
-}
-
-multilib_src_install_all() {
- insinto /etc/gtk-3.0
- doins "${FILESDIR}"/settings.ini
- # Skip README.{in,commits,win32} and useless ChangeLog that would get installed by default
- DOCS=( AUTHORS NEWS README )
- einstalldocs
-}
-
-pkg_preinst() {
- gnome2_pkg_preinst
-
- multilib_pkg_preinst() {
- # Make immodules.cache belongs to gtk+ alone
- local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
-
- if [[ -e ${EROOT}${cache} ]]; then
- cp "${EROOT}"${cache} "${ED}"/${cache} || die
- else
- touch "${ED}"/${cache} || die
- fi
- }
- multilib_parallel_foreach_abi multilib_pkg_preinst
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- multilib_pkg_postinst() {
- gnome2_query_immodules_gtk3 \
- || die "Update immodules cache failed (for ${ABI})"
- }
- multilib_parallel_foreach_abi multilib_pkg_postinst
-
- if ! has_version "app-text/evince"; then
- elog "Please install app-text/evince for print preview functionality."
- elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
- elog "add it to your settings.ini file."
- fi
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
-
- if [[ -z ${REPLACED_BY_VERSION} ]]; then
- multilib_pkg_postrm() {
- rm -f "${EROOT}"usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache
- }
- multilib_foreach_abi multilib_pkg_postrm
- fi
-}