summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/fvwm-crystal')
-rw-r--r--x11-themes/fvwm-crystal/Manifest1
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.4.1-r2.ebuild94
-rw-r--r--x11-themes/fvwm-crystal/metadata.xml27
3 files changed, 122 insertions, 0 deletions
diff --git a/x11-themes/fvwm-crystal/Manifest b/x11-themes/fvwm-crystal/Manifest
new file mode 100644
index 00000000..567db149
--- /dev/null
+++ b/x11-themes/fvwm-crystal/Manifest
@@ -0,0 +1 @@
+DIST fvwm-crystal-3.4.1.tar.gz 5663772 SHA512 c033cc27a523a69c7735bde3b5885381e2a338d4f84b4089050be44e04bbb490492d826f899bf16bf5c167044eae330f954320b4bb14647e4db2a4b6b5d32009
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.4.1-r2.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.4.1-r2.ebuild
new file mode 100644
index 00000000..1bf9057c
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.4.1-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2020 Gentoo Authors and Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+inherit eutils readme.gentoo-r1 python-r1 user
+
+DESCRIPTION="Configurable FVWM theme with transparency and freedesktop compatible menu"
+HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+case ${PV} in
+*9999)
+ inherit subversion
+ ESVN_REPO_URI="svn://svn.code.sf.net/p/fvwm-crystal/code"
+ SRC_URI=""
+ KEYWORDS=""
+ S="${WORKDIR}/${PN}"
+ src_unpack() {
+ subversion_src_unpack
+ };;
+esac
+
+BDEPEND="sys-apps/sed"
+RDEPEND="${PYTHON_DEPS}
+ >=x11-wm/fvwm-2.5.26[png]
+ virtual/imagemagick-tools
+ || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
+ || ( x11-misc/hsetroot media-gfx/feh )
+ $BDEPEND
+ sys-devel/bc
+ virtual/awk
+ x11-apps/xwd
+ media-sound/alsa-utils"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="After installation, execute the following commands:
+ $ cp -r "${EROOT}"usr/share/doc/"${PF}"/addons/Xresources ~/.Xresources
+ $ cp -r "${EROOT}"usr/share/doc/"${PF}"/addons/Xsession ~/.xinitrc
+
+Many applications can extend functionality of fvwm-crystal.
+They are listed in "${EROOT}"usr/share/doc/"${PF}"/INSTALL.*
+
+To be able to use the exit menu, each user using ${PN}
+must be in the group fvwm-crystal.
+You can do that as root with:
+ $ useradd -G fvwm-crystal <user_name>
+and log out and in again.
+"
+
+pkg_setup() {
+ enewgroup fvwm-crystal
+}
+
+src_prepare() {
+ sed -i -e '1s/python2/python/' \
+ -e 's/^\([[:space:]]*print\)[[:space:]]\(.*\)$/\1(\2)/' -- \
+ "${S}"/bin/"${PN}".{apps,wallpaper} \
+ "${S}"/fvwm/scripts/FvwmMPD/*.py || die
+ default
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
+ # GNU License is globally in the portage tree
+ rm -vf "${ED}/usr/share/doc/${PF}"/LICENSE
+
+ python_replicate_script \
+ "${ED}/usr/bin/${PN}".{apps,wallpaper} \
+ "${ED}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ elog "Many applications can extend functionality of fvwm-crystal."
+ elog "They are listed in ${EROOT}usr/share/doc/${PF}/INSTALL.bz2"
+ elog "Popular supported softwares are:"
+ elog "- x11-misc/xdg-user-dirs (the gtk USE is not needed) to"
+ elog " get localized XDG user directories support"
+ elog "- sys-power/pm-utils for hibernate/resume support"
+ elog "- media-sound/jack-audio-connection-kit for a professional sound server"
+ elog "- several media players"
+}
diff --git a/x11-themes/fvwm-crystal/metadata.xml b/x11-themes/fvwm-crystal/metadata.xml
new file mode 100644
index 00000000..951da7f2
--- /dev/null
+++ b/x11-themes/fvwm-crystal/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dominique.c.michel@gmail.com</email>
+ <name>Dominique Michel</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+FVWM-Crystal is a set of configuration files for FVWM window manager,
+with additional programs and scripts. Some of it's features are:
+ * quick launching of a terminal with just one click on a desktop
+ * a specially configured terminal window, similar to a console from FPP games
+ * builtin control over XMMS player and over aumix mixer from the keyboard and
+ buttons on the screen
+ * very good ability to control the desktop from the keyboard, including window
+ switching, moving, shading/unshading, maximizing, resizing, moving between
+ desktop pages
+ * transparent window titlebars, menus and panels on the desktop
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">fvwm-crystal</remote-id>
+ </upstream>
+</pkgmetadata>