summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Kaiser <nikai@nikai.net>2010-08-10 17:56:07 +0200
committerNicolas Kaiser <nikai@nikai.net>2010-08-10 17:56:07 +0200
commit47943a3d628c88b4ffdac2e247e0e64e95f8e893 (patch)
treeb8d5fa28b0e3e21a683999863fdde60a36851d00 /dev-util
parentvs: add mesher USE flag (diff)
downloadnikai-47943a3d628c88b4ffdac2e247e0e64e95f8e893.tar.gz
nikai-47943a3d628c88b4ffdac2e247e0e64e95f8e893.tar.bz2
nikai-47943a3d628c88b4ffdac2e247e0e64e95f8e893.zip
jansson, radeondb: initial commit
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/radeondb/Manifest2
-rw-r--r--dev-util/radeondb/metadata.xml9
-rw-r--r--dev-util/radeondb/radeondb-9999.ebuild52
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-util/radeondb/Manifest b/dev-util/radeondb/Manifest
new file mode 100644
index 0000000..1212e42
--- /dev/null
+++ b/dev-util/radeondb/Manifest
@@ -0,0 +1,2 @@
+EBUILD radeondb-9999.ebuild 809 RMD160 04e1e5fdadd3ba5225a56bbf26c688595b5a6255 SHA1 483a8338f61d367882b5c1a1ffbde2e2d6bb865f SHA256 530764a60e92e5cde83dc913d35bc9df882eab04f757805f47205f5a49555d5b
+MISC metadata.xml 564 RMD160 d84fc01ce284b2d676ff74eb538057dee6e44ed3 SHA1 0aa1a7bfeec3ae9d25516d531c5b5bb512c5cb6d SHA256 e3f8d17ec47a694e6061fd5c5a029af1259f0b3b0bf6e6e8adcdb7eedcbe9cdb
diff --git a/dev-util/radeondb/metadata.xml b/dev-util/radeondb/metadata.xml
new file mode 100644
index 0000000..cd1082d
--- /dev/null
+++ b/dev-util/radeondb/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>nikai@nikai.net</email>
+</maintainer>
+<longdescription>A radeon debugger, that allows to replay the GPU command stream. The command stream is captured by setting CS_BOF_DUMP to 1. Note that this will produce a new file for every CS, which may be huge depending on the size of textures used. Replaying CS needs to be run outside X with KMS enabled, and as root.</longdescription>
+</pkgmetadata>
diff --git a/dev-util/radeondb/radeondb-9999.ebuild b/dev-util/radeondb/radeondb-9999.ebuild
new file mode 100644
index 0000000..472c3f9
--- /dev/null
+++ b/dev-util/radeondb/radeondb-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/~glisse/radeondb"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git"
+fi
+
+inherit autotools eutils ${GIT_ECLASS}
+
+DESCRIPTION="a Radeon debugging tool for replaying GPU command stream"
+
+HOMEPAGE="http://jglisse.livejournal.com/"
+
+LICENSE="GPL-3"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="dev-libs/jansson"
+RDEPEND="${DEPEND}"
+
+#S="${WORKDIR}/${P}"
+
+src_unpack() {
+ [[ $PV = 9999* ]] && git_src_unpack
+}
+
+src_prepare() {
+ [[ $PV = 9999* ]] && git_src_prepare
+
+ eautoreconf
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}