summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Kaiser <nikai@nikai.net>2010-07-30 15:40:41 +0200
committerNicolas Kaiser <nikai@nikai.net>2010-07-30 15:40:41 +0200
commita30aa389808ecf0259d21a5a812bfe50b73d6b70 (patch)
treee8c6f351bd4b488e9d5efb5bf20dc237718d45d0 /games-simulation
parentvs-data: adding correct datadir (diff)
downloadnikai-a30aa389808ecf0259d21a5a812bfe50b73d6b70.tar.gz
nikai-a30aa389808ecf0259d21a5a812bfe50b73d6b70.tar.bz2
nikai-a30aa389808ecf0259d21a5a812bfe50b73d6b70.zip
vs: added boost USE flag, skipped bootstrap
For the moment, USE flags only pull in optional deps.
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/vegastrike/Manifest4
-rw-r--r--games-simulation/vegastrike/metadata.xml3
-rw-r--r--games-simulation/vegastrike/vegastrike-9999.ebuild5
3 files changed, 7 insertions, 5 deletions
diff --git a/games-simulation/vegastrike/Manifest b/games-simulation/vegastrike/Manifest
index 7b8b3e9..c03f219 100644
--- a/games-simulation/vegastrike/Manifest
+++ b/games-simulation/vegastrike/Manifest
@@ -1,2 +1,2 @@
-EBUILD vegastrike-9999.ebuild 4064 RMD160 24bbe71d665cf9aaece5f94a557435d0f6dcdaac SHA1 e32027cf77650930aedab0822c3edba931641a89 SHA256 a874fdf7ed5adaaac7bbde8f2bbacf34e4621d0c47892460ac28921f40b60ee6
-MISC metadata.xml 661 RMD160 9590d3f59a89cefc68fc8d47a51e070c8ad62355 SHA1 ef1c5ae3612fd06b27369eb7e73dbf5d79439af7 SHA256 b84cf9e11ce628e37a3778ce5f1ce28a93e803847e5fc168130d039f396c8cf9
+EBUILD vegastrike-9999.ebuild 4122 RMD160 a4d5e108f64bb8c0a0d1c623220181cf08b8df34 SHA1 5b7baa2f0d937481d00d6c7da5ba94bb0e13cc80 SHA256 6a711a782c8686bda06f0e974a4d72a8eb5995e1a8aaa9800b98f5eb7174107e
+MISC metadata.xml 792 RMD160 37d782449538030c26821001db9a0287355ec8d0 SHA1 2baec92dae0593cc10a2b57b694af333df4fe0a0 SHA256 bf8f677f4555c04febfd6a81115f5efeaf0cb0b5be9f7fd0a542a9db8a688bb5
diff --git a/games-simulation/vegastrike/metadata.xml b/games-simulation/vegastrike/metadata.xml
index cc2f6aa..31df043 100644
--- a/games-simulation/vegastrike/metadata.xml
+++ b/games-simulation/vegastrike/metadata.xml
@@ -7,8 +7,9 @@
</maintainer>
<longdescription>Vega Strike is an Open Source 3D Action-Space-Sim that lets you trade, fight, and explore in a vast universe. The vegastrike branch contains the game source code.</longdescription>
<use>
+ <flag name='boost'>Enable support for system <pkg>dev-libs/boost</pkg> instead of included one. Recommended.</flag>
<flag name='gtk'>Uses <pkg>x11-libs/gtk+</pkg> for graphical configuration (vssetup).</flag>
- <flag name='ffmpeg'>Enables support for <pkg>media-video/ffmpeg</pkg>.</flag>
+ <flag name='ffmpeg'>Enables support for <pkg>media-video/ffmpeg</pkg>. Recommended.</flag>
<flag name='debug'>Enable debugging support.</flag>
</use>
</pkgmetadata>
diff --git a/games-simulation/vegastrike/vegastrike-9999.ebuild b/games-simulation/vegastrike/vegastrike-9999.ebuild
index ae62039..20e4855 100644
--- a/games-simulation/vegastrike/vegastrike-9999.ebuild
+++ b/games-simulation/vegastrike/vegastrike-9999.ebuild
@@ -9,20 +9,21 @@ inherit cmake-utils flag-o-matic eutils games
ESVN_REPO_URI="https://vegastrike.svn.sourceforge.net/svnroot/vegastrike/trunk"
ESVN_PROJECT="vegastrike"
#ESVN_BOOTSTRAP="vegastrike/bootstrap-sh"
-ESVN_BOOTSTRAP=""
+ESVN_BOOTSTRAP="echo 'skipping bootstrap'"
DESCRIPTION="A 3D space simulator that allows you to trade and bounty hunt"
HOMEPAGE="http://vegastrike.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="ffmpeg gtk debug"
+IUSE="boost ffmpeg gtk debug"
# FIXME: check dependencies
RDEPEND="
virtual/opengl
media-libs/jpeg
media-libs/libpng
+ boost? ( dev-libs/boost )
dev-libs/expat
media-libs/openal
media-libs/libsdl