summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtur Maciąg <maciag.artur@gmail.com>2010-04-17 20:36:29 +0200
committerArtur Maciąg <maciag.artur@gmail.com>2010-04-17 20:36:29 +0200
commit9aa6a07af6b64f1e425cecadf3297b45ef6e98e2 (patch)
treebe6250a07f20701960dc62fd1b989c76fcfbd0f9
downloadpiczu-9aa6a07af6b64f1e425cecadf3297b45ef6e98e2.tar.gz
piczu-9aa6a07af6b64f1e425cecadf3297b45ef6e98e2.tar.bz2
piczu-9aa6a07af6b64f1e425cecadf3297b45ef6e98e2.zip
Initial commit
-rw-r--r--profiles/repo_name1
-rw-r--r--sys-fs/btrfs-progs/Manifest5
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-0.19.ebuild95
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-9999.ebuild90
-rw-r--r--sys-fs/btrfs-progs/files/btrfs-progs-0.18-apple.patch319
-rw-r--r--sys-fs/btrfs-progs/files/btrfs-progs-0.19-convert-remove-used-space-update.patch30
-rw-r--r--x11-themes/gtk-engines-nodoka/Manifest3
-rw-r--r--x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.2.ebuild44
-rw-r--r--x11-themes/gtk-engines-quartz/Manifest1
-rw-r--r--x11-themes/gtk-engines-quartz/gtk-engines-quartz-9999.ebuild45
10 files changed, 633 insertions, 0 deletions
diff --git a/profiles/repo_name b/profiles/repo_name
new file mode 100644
index 0000000..7f6ef00
--- /dev/null
+++ b/profiles/repo_name
@@ -0,0 +1 @@
+piczu
diff --git a/sys-fs/btrfs-progs/Manifest b/sys-fs/btrfs-progs/Manifest
new file mode 100644
index 0000000..d1f0379
--- /dev/null
+++ b/sys-fs/btrfs-progs/Manifest
@@ -0,0 +1,5 @@
+AUX btrfs-progs-0.18-apple.patch 8206 RMD160 c1b357febe3fef150ee36ba68f8b2fb6a6338dde SHA1 bd14ae194627eeb7a88606c421fbd9e56511f0c2 SHA256 ee579e9c18eb88c1e740361e0270fe523328fb30a2a52366fff27ee74d214f43
+AUX btrfs-progs-0.19-convert-remove-used-space-update.patch 1005 RMD160 52925f470e96f851f74862fa0ac9cf7bc729c536 SHA1 49636f68528d1faacc0d8a72be63862e4e3a672c SHA256 75759924f7d766705c5ea97d4cc2d70962b4c49e7f274465c3c2e9021d481f38
+DIST btrfs-progs-0.19.tar.bz2 118119 RMD160 28e7955fd1f9e0ac68c465cf3bbeec3c889b0513 SHA1 483b44e844c3a97ccb830add21ca9327545dbc69 SHA256 f8a3dd03e87a33506d16ccc1e5a77c4c38ff1fa84b9502ed4b88c0b39fab70fc
+EBUILD btrfs-progs-0.19.ebuild 2603 RMD160 eaf627bad5d42be5bd20a68e382a2265cd3680cc SHA1 2e8ea8fafb1c546a28fc87bdd8e2a95192ff2fe8 SHA256 a1e2b0c00647b703e5364ee1ae3f61b90a71eabeb75aaad4a7798bcd663ccc3e
+EBUILD btrfs-progs-9999.ebuild 2311 RMD160 0c1451e2b68d5ad2df76b70e4fe640d6f1981177 SHA1 c1e0ffdc86cf9d77bee607ae4bab044acb3bc97d SHA256 2cea9afb4023ed2fb5a10560e1da3345f611d9b1f570fd6432e0648907bf63e8
diff --git a/sys-fs/btrfs-progs/btrfs-progs-0.19.ebuild b/sys-fs/btrfs-progs/btrfs-progs-0.19.ebuild
new file mode 100644
index 0000000..70d53c6
--- /dev/null
+++ b/sys-fs/btrfs-progs/btrfs-progs-0.19.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs-progs/btrfs-progs-0.19.ebuild,v 1.2 2009/12/25 12:10:32 armin76 Exp $
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Btrfs filesystem utilities"
+HOMEPAGE="http://btrfs.wiki.kernel.org/"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/people/mason/btrfs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x64-macos"
+IUSE="acl debug-utils"
+
+DEPEND="debug-utils? ( dev-python/matplotlib )
+ acl? (
+ sys-apps/acl
+ sys-fs/e2fsprogs
+ )
+ dev-libs/ossp-uuid"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Darwin specific patch
+ epatch "${FILESDIR}/${PN}-0.18-apple.patch"
+ # Remove code that updates the total used space, since
+ # btrfs_update_block_group does that work now.
+ # (patch that did not make 0.19 release)
+ epatch "${FILESDIR}/${P}-convert-remove-used-space-update.patch"
+
+ # Fix hardcoded "gcc" and "make"
+ sed -i -e 's:gcc $(CFLAGS):$(CC) $(CFLAGS):' Makefile
+ sed -i -e 's:make:$(MAKE):' Makefile
+ # Fix ossp-uuid library gentooish name
+ sed -i -e 's:-luuid:-lossp-uuid' Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ all || die
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ btrfstune btrfs-image || die
+ if use acl; then
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ convert || die
+ fi
+}
+
+src_install() {
+ into /
+ dosbin btrfs-show
+ dosbin btrfs-vol
+ dosbin btrfsctl
+ dosbin btrfsck
+ dosbin btrfstune
+ dosbin btrfs-image
+ # fsck will segfault if invoked at boot, so do not make this link
+ #dosym btrfsck /sbin/fsck.btrfs
+ newsbin mkfs.btrfs mkbtrfs
+ dosym mkbtrfs /sbin/mkfs.btrfs
+ if use acl; then
+ dosbin btrfs-convert
+ else
+ ewarn "Note: btrfs-convert not built/installed (requires acl USE flag)"
+ fi
+
+ if use debug-utils; then
+ dobin btrfs-debug-tree
+ else
+ ewarn "Note: btrfs-debug-tree not installed (requires debug-utils USE flag)"
+ fi
+
+ into /usr
+ newbin bcp btrfs-bcp
+
+ if use debug-utils; then
+ newbin show-blocks btrfs-show-blocks
+ else
+ ewarn "Note: btrfs-show-blocks not installed (requires debug-utils USE flag)"
+ fi
+
+ dodoc INSTALL
+ emake prefix="${D}${EPREFIX}/usr/share" install-man
+}
+
+pkg_postinst() {
+ ewarn "WARNING: This version of btrfs-progs corresponds to and should only"
+ ewarn " be used with the version of btrfs included in the"
+ ewarn " Linux kernel (2.6.31 and above)."
+ ewarn ""
+ ewarn " This version should NOT be used with earlier versions"
+ ewarn " of the standalone btrfs module!"
+}
diff --git a/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
new file mode 100644
index 0000000..5954855
--- /dev/null
+++ b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild,v 1.12 2009/11/14 16:32:10 scarabeus Exp $
+EAPI="2"
+
+inherit eutils git
+
+DESCRIPTION="Btrfs filesystem utilities"
+HOMEPAGE="http://btrfs.wiki.kernel.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x64-macos"
+IUSE="acl debug-utils"
+
+DEPEND="debug-utils? ( dev-python/matplotlib )
+ acl? (
+ sys-apps/acl
+ sys-fs/e2fsprogs
+ )
+ dev-libs/ossp-uuid"
+RDEPEND="${DEPEND}"
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/mason/btrfs-progs-unstable.git"
+EGIT_BRANCH="master"
+
+src_prepare() {
+ # Darvin specific fix
+ epatch "${FILESDIR}/${PN}-0.18-apple.patch"
+ # Fix hardcoded "gcc" and "make"
+ sed -i -e 's:gcc $(CFLAGS):$(CC) $(CFLAGS):' Makefile
+ sed -i -e 's:make:$(MAKE):' Makefile
+ # Fix ossp-uuid library gentooish name
+ sed -i -e 's:-luuid:-lossp-uuid' Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ all || die
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ btrfstune btrfs-image || die
+ if use acl; then
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ convert || die
+ fi
+}
+
+src_install() {
+ into /
+ dosbin btrfs-show
+ dosbin btrfs-vol
+ dosbin btrfsctl
+ dosbin btrfsck
+ dosbin btrfstune
+ dosbin btrfs-image
+ # fsck will segfault if invoked at boot, so do not make this link
+ #dosym btrfsck /sbin/fsck.btrfs
+ newsbin mkfs.btrfs mkbtrfs
+ dosym mkbtrfs /sbin/mkfs.btrfs
+ if use acl; then
+ dosbin btrfs-convert
+ else
+ ewarn "Note: btrfs-convert not built/installed (requires acl USE flag)"
+ fi
+
+ if use debug-utils; then
+ dobin btrfs-debug-tree
+ else
+ ewarn "Note: btrfs-debug-tree not installed (requires debug-utils USE flag)"
+ fi
+
+ into /usr
+ newbin bcp btrfs-bcp
+
+ if use debug-utils; then
+ newbin show-blocks btrfs-show-blocks
+ else
+ ewarn "Note: btrfs-show-blocks not installed (requires debug-utils USE flag)"
+ fi
+
+ dodoc INSTALL
+ emake prefix="${D}/usr/share" install-man
+}
+
+pkg_postinst() {
+ ewarn "WARNING: This version of btrfs-progs uses the latest unstable code,"
+ ewarn " and care should be taken that it is compatible with the"
+ ewarn " version of btrfs in your kernel!"
+}
diff --git a/sys-fs/btrfs-progs/files/btrfs-progs-0.18-apple.patch b/sys-fs/btrfs-progs/files/btrfs-progs-0.18-apple.patch
new file mode 100644
index 0000000..8770fa9
--- /dev/null
+++ b/sys-fs/btrfs-progs/files/btrfs-progs-0.18-apple.patch
@@ -0,0 +1,319 @@
+--- btrfs-image.c.orig 2009-02-15 14:49:17.000000000 +0100
++++ btrfs-image.c 2009-02-15 12:42:10.000000000 +0100
+@@ -249,7 +249,7 @@
+ static int metadump_init(struct metadump_struct *md, struct btrfs_root *root,
+ FILE *out, int num_threads, int compress_level)
+ {
+- int i, ret;
++ int i, ret = 0;
+
+ memset(md, 0, sizeof(*md));
+ pthread_cond_init(&md->cond, NULL);
+@@ -608,7 +608,11 @@
+ if (async->start == BTRFS_SUPER_INFO_OFFSET)
+ update_super(outbuf);
+
++#ifdef __APPLE__
++ ret = pwrite(outfd, outbuf, size, async->start);
++#else
+ ret = pwrite64(outfd, outbuf, size, async->start);
++#endif
+ BUG_ON(ret != size);
+
+ pthread_mutex_lock(&mdres->mutex);
+@@ -834,7 +838,9 @@
+ }
+
+ if (num_threads == 0 && compress_level > 0) {
++#ifdef _SC_NPROCESSORS_ONLN
+ num_threads = sysconf(_SC_NPROCESSORS_ONLN);
++#endif
+ if (num_threads <= 0)
+ num_threads = 1;
+ }
+--- btrfsck.c.orig 2009-02-15 14:40:07.000000000 +0100
++++ btrfsck.c 2009-02-15 12:32:04.000000000 +0100
+@@ -21,6 +21,9 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <fcntl.h>
++
++#include <sys/stat.h>
++
+ #include "kerncompat.h"
+ #include "ctree.h"
+ #include "disk-io.h"
+--- disk-io.c.orig 2009-02-15 13:35:46.000000000 +0100
++++ disk-io.c 2009-02-14 20:41:42.000000000 +0100
+@@ -143,7 +143,11 @@
+ device = multi->stripes[0].dev;
+ device->total_ios++;
+ blocksize = min(blocksize, (u32)(64 * 1024));
++#ifdef __APPLE__
++ read(device->fd, &multi->stripes[0].physical, blocksize);
++#else
+ readahead(device->fd, multi->stripes[0].physical, blocksize);
++#endif
+ kfree(multi);
+ return 0;
+ }
+@@ -699,7 +703,11 @@
+ u64 bytenr;
+
+ if (sb_bytenr != BTRFS_SUPER_INFO_OFFSET) {
++#ifdef __APPLE__
++ ret = pread(fd, &buf, sizeof(buf), sb_bytenr);
++#else
+ ret = pread64(fd, &buf, sizeof(buf), sb_bytenr);
++#endif
+ if (ret < sizeof(buf))
+ return -1;
+
+@@ -714,7 +722,11 @@
+
+ for (i = 0; i < BTRFS_SUPER_MIRROR_MAX; i++) {
+ bytenr = btrfs_sb_offset(i);
++#ifdef __APPLE__
++ ret = pread(fd, &buf, sizeof(buf), bytenr);
++#else
+ ret = pread64(fd, &buf, sizeof(buf), bytenr);
++#endif
+ if (ret < sizeof(buf))
+ break;
+
+@@ -747,8 +759,13 @@
+ BTRFS_SUPER_INFO_SIZE - BTRFS_CSUM_SIZE);
+ btrfs_csum_final(crc, (char *)&sb->csum[0]);
+
++#ifdef __APPLE__
++ ret = pwrite(device->fd, sb, BTRFS_SUPER_INFO_SIZE,
++ root->fs_info->super_bytenr);
++#else
+ ret = pwrite64(device->fd, sb, BTRFS_SUPER_INFO_SIZE,
+ root->fs_info->super_bytenr);
++#endif
+ BUG_ON(ret != BTRFS_SUPER_INFO_SIZE);
+ return 0;
+ }
+@@ -765,7 +782,11 @@
+ BTRFS_SUPER_INFO_SIZE - BTRFS_CSUM_SIZE);
+ btrfs_csum_final(crc, (char *)&sb->csum[0]);
+
++#ifdef __APPLE__
++ ret = pwrite(device->fd, sb, BTRFS_SUPER_INFO_SIZE, bytenr);
++#else
+ ret = pwrite64(device->fd, sb, BTRFS_SUPER_INFO_SIZE, bytenr);
++#endif
+ BUG_ON(ret != BTRFS_SUPER_INFO_SIZE);
+ }
+ return 0;
+--- extent-tree.c.orig 2009-02-15 13:39:33.000000000 +0100
++++ extent-tree.c 2009-02-14 20:43:40.000000000 +0100
+@@ -2564,7 +2564,7 @@
+ u64 total_metadata = 0;
+ u64 chunk_objectid;
+ int ret;
+- int bit;
++ int bit = 0;
+ struct btrfs_root *extent_root;
+ struct btrfs_block_group_cache *cache;
+ struct extent_io_tree *block_group_cache;
+--- file-item.c.orig 2009-02-15 13:41:47.000000000 +0100
++++ file-item.c 2009-02-14 20:44:17.000000000 +0100
+@@ -193,7 +193,7 @@
+ struct btrfs_root *root, u64 alloc_end,
+ u64 bytenr, char *data, size_t len)
+ {
+- int ret;
++ int ret = 0;
+ struct btrfs_key file_key;
+ struct btrfs_key found_key;
+ u64 next_offset = (u64)-1;
+--- ioctl.h.orig 2009-02-15 13:46:49.000000000 +0100
++++ ioctl.h 2009-02-15 13:48:54.000000000 +0100
+@@ -18,15 +18,23 @@
+
+ #ifndef __IOCTL_
+ #define __IOCTL_
++#ifndef __APPLE__
+ #include <asm/types.h>
+ #include <linux/ioctl.h>
++#endif
++
++#include <stdint.h>
+
+ #define BTRFS_IOCTL_MAGIC 0x94
+ #define BTRFS_VOL_NAME_MAX 255
+ #define BTRFS_PATH_NAME_MAX 4087
+
+ struct btrfs_ioctl_vol_args {
++#ifdef __APPLE__
++ int64_t fd;
++#else
+ __s64 fd;
++#endif
+ char name[BTRFS_PATH_NAME_MAX + 1];
+ };
+
+--- kerncompat.h.orig 2009-02-15 13:25:46.000000000 +0100
++++ kerncompat.h 2009-02-15 13:28:49.000000000 +0100
+@@ -22,8 +22,13 @@
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <string.h>
++#ifdef __APPLE__
++#include <stdint.h>
++#include <libkern/OSByteOrder.h>
++#else
+ #include <endian.h>
+ #include <byteswap.h>
++#endif
+ #include <assert.h>
+
+ #ifndef READ
+@@ -42,7 +47,7 @@
+ #define GFP_NOFS 0
+ #define __read_mostly
+ #define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
+-#define ULONG_MAX (~0UL)
++//#define ULONG_MAX (~0UL)
+ #define BUG() abort()
+ #ifdef __CHECKER__
+ #define __force __attribute__((force))
+@@ -53,11 +58,18 @@
+ #endif
+
+ #ifndef __CHECKER__
++#ifdef __APPLE__
++typedef uint32_t u32;
++typedef uint64_t u64;
++typedef uint16_t u16;
++typedef uint8_t u8;
++#else
+ #include <asm/types.h>
+ typedef __u32 u32;
+ typedef __u64 u64;
+ typedef __u16 u16;
+ typedef __u8 u8;
++#endif /* __APPLE__ */
+ #else
+ typedef unsigned int u32;
+ typedef unsigned int __u32;
+@@ -236,12 +248,21 @@
+ #define __le8 u8
+
+ #if __BYTE_ORDER == __BIG_ENDIAN
++#ifdef __APPLE__
++#define cpu_to_le64(x) ((__force __le64)(u64)(OSSwapHostToLittleInt64(x)))
++#define le64_to_cpu(x) ((__force u64)(__le64)(OSSwapLittleToHostInt64(x)))
++#define cpu_to_le32(x) ((__force __le32)(u32)(OSSwapHostToLittleInt32(x)))
++#define le32_to_cpu(x) ((__force u32)(__le32)(OSSwapLittleToHostInt32(x)))
++#define cpu_to_le16(x) ((__force __le16)(u16)(OSSwapHostToLittleInt16(x)))
++#define le16_to_cpu(x) ((__force u16)(__le16)(OSSwapLittleToHostInt16(x)))
++#else
+ #define cpu_to_le64(x) ((__force __le64)(u64)(bswap_64(x)))
+ #define le64_to_cpu(x) ((__force u64)(__le64)(bswap_64(x)))
+ #define cpu_to_le32(x) ((__force __le32)(u32)(bswap_32(x)))
+ #define le32_to_cpu(x) ((__force u32)(__le32)(bswap_32(x)))
+ #define cpu_to_le16(x) ((__force __le16)(u16)(bswap_16(x)))
+ #define le16_to_cpu(x) ((__force u16)(__le16)(bswap_16(x)))
++#endif /* __APPLE__ */
+ #else
+ #define cpu_to_le64(x) ((__force __le64)(u64)(x))
+ #define le64_to_cpu(x) ((__force u64)(__le64)(x))
+--- list.h.orig 2009-02-15 13:57:31.000000000 +0100
++++ list.h 2009-02-14 20:55:04.000000000 +0100
+@@ -38,7 +38,7 @@
+
+ #define LIST_HEAD_INIT(name) { &(name), &(name) }
+
+-#define LIST_HEAD(name) \
++#define BTRFS_LIST_HEAD(name) \
+ struct list_head name = LIST_HEAD_INIT(name)
+
+ static inline void INIT_LIST_HEAD(struct list_head *list)
+--- mkfs.c.orig 2009-02-15 14:42:49.000000000 +0100
++++ mkfs.c 2009-02-15 14:47:19.000000000 +0100
+@@ -18,6 +18,7 @@
+
+ #define _XOPEN_SOURCE 500
+ #define _GNU_SOURCE
++#define _DARWIN_C_SOURCE
+
+ #ifndef __CHECKER__
+ #include <sys/ioctl.h>
+@@ -33,7 +34,9 @@
+ #include <unistd.h>
+ #include <getopt.h>
+ #include <uuid/uuid.h>
++#ifndef __APPLE__
+ #include <linux/fs.h>
++#endif
+ #include <ctype.h>
+ #include "kerncompat.h"
+ #include "ctree.h"
+--- utils.c.orig 2009-02-15 13:52:25.000000000 +0100
++++ utils.c 2009-02-15 13:53:35.000000000 +0100
+@@ -18,6 +18,7 @@
+
+ #define _XOPEN_SOURCE 600
+ #define __USE_XOPEN2K
++#define _DARWIN_C_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #ifndef __CHECKER__
+@@ -30,7 +31,13 @@
+ #include <dirent.h>
+ #include <fcntl.h>
+ #include <unistd.h>
++#ifdef __APPLE__
++#include <sys/disk.h>
++#else
+ #include <mntent.h>
++#endif
++
++
+ #include "kerncompat.h"
+ #include "radix-tree.h"
+ #include "ctree.h"
+@@ -393,7 +400,11 @@
+ if (!S_ISBLK(st->st_mode)) {
+ return 0;
+ }
++#ifdef __APPLE__
++ if (ioctl(fd, DKIOCGETBLOCKCOUNT, &size) >= 0) {
++#else
+ if (ioctl(fd, BLKGETSIZE64, &size) >= 0) {
++#endif
+ return size;
+ }
+ return 0;
+@@ -594,6 +605,9 @@
+ */
+ int check_mounted(char *file)
+ {
++#ifdef __APPLE__
++ return 0;
++#else
+ struct mntent *mnt;
+ struct stat st_buf;
+ dev_t file_dev = 0;
+@@ -638,6 +652,7 @@
+
+ endmntent (f);
+ return ret;
++#endif
+ }
+
+ struct pending_dir {
+--- volumes.c.orig 2009-02-15 14:02:34.000000000 +0100
++++ volumes.c 2009-02-14 20:55:25.000000000 +0100
+@@ -50,7 +50,7 @@
+ #define map_lookup_size(n) (sizeof(struct map_lookup) + \
+ (sizeof(struct btrfs_bio_stripe) * (n)))
+
+-static LIST_HEAD(fs_uuids);
++static BTRFS_LIST_HEAD(fs_uuids);
+
+ static struct btrfs_device *__find_device(struct list_head *head, u64 devid,
+ u8 *uuid)
diff --git a/sys-fs/btrfs-progs/files/btrfs-progs-0.19-convert-remove-used-space-update.patch b/sys-fs/btrfs-progs/files/btrfs-progs-0.19-convert-remove-used-space-update.patch
new file mode 100644
index 0000000..e326f34
--- /dev/null
+++ b/sys-fs/btrfs-progs/files/btrfs-progs-0.19-convert-remove-used-space-update.patch
@@ -0,0 +1,30 @@
+--- /var/tmp/portage/sys-fs/btrfs-progs-0.19/work/btrfs-progs-0.19/convert.c 2009-06-11 10:56:15.000000000 -0600
++++ btrfs-progs-unstable/convert.c 2009-09-21 08:51:43.773575874 -0600
+@@ -370,7 +370,6 @@
+ struct btrfs_extent_item *ei;
+ u32 blocksize = root->sectorsize;
+ u64 nbytes;
+- u64 bytes_used;
+
+ if (disk_bytenr == 0) {
+ ret = btrfs_insert_file_extent(trans, root, objectid,
+@@ -432,9 +431,6 @@
+ nbytes = btrfs_stack_inode_nbytes(inode) + num_bytes;
+ btrfs_set_stack_inode_nbytes(inode, nbytes);
+
+- bytes_used = btrfs_root_used(&root->root_item);
+- btrfs_set_root_used(&root->root_item, bytes_used + num_bytes);
+-
+ btrfs_release_path(root, &path);
+
+ ins_key.objectid = disk_bytenr;
+@@ -454,9 +450,6 @@
+
+ btrfs_mark_buffer_dirty(leaf);
+
+- bytes_used = btrfs_super_bytes_used(&info->super_copy);
+- btrfs_set_super_bytes_used(&info->super_copy, bytes_used +
+- num_bytes);
+ ret = btrfs_update_block_group(trans, root, disk_bytenr,
+ num_bytes, 1, 0);
+ if (ret)
diff --git a/x11-themes/gtk-engines-nodoka/Manifest b/x11-themes/gtk-engines-nodoka/Manifest
new file mode 100644
index 0000000..407da39
--- /dev/null
+++ b/x11-themes/gtk-engines-nodoka/Manifest
@@ -0,0 +1,3 @@
+DIST gtk-nodoka-engine-0.7.2.tar.gz 362217 RMD160 d22899ed36a795e1aa0482a68205063df1695614 SHA1 7bc8c778cfb76717a2881b7524daa4a7acf3a16b SHA256 e4e6952c954e7d1226d759b1a79e3fbc41a3b9c27e106ea05db5172e3dceb768
+DIST nodoka-theme-gnome-0.3.90.tar.gz 17792 RMD160 85bde1abdc27b58fa8aca561ab5c4d363f030d64 SHA1 de64d5cc11f8fb78f3f1e0e0a4490c707c2268ce SHA256 4bfd60fdcfa58dba701022d75fe377d0eabe3f77159c913dd0de6acbcd0df392
+EBUILD gtk-engines-nodoka-0.7.2.ebuild 1057 RMD160 5273d7a64a49b373ad323e5c88630e4b12f9b906 SHA1 82ba1bcd80ee1055b747596633a50945e3a7d58f SHA256 91299d2aa0f191ea50578c7a308616ab5943660caa70d39d27456448590e7d5f
diff --git a/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.2.ebuild b/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.2.ebuild
new file mode 100644
index 0000000..a34ba60
--- /dev/null
+++ b/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI="2"
+
+inherit eutils
+
+MY_PN="nodoka"
+MY_P="gtk-${MY_PN}-engine-${PV}"
+MY_P2="${MY_PN}-theme-gnome-0.3.90"
+DESCRIPTION="Nodoka GTK+2 Engine"
+
+HOMEPAGE="https://fedorahosted.org/nodoka/"
+SRC_URI="https://fedorahosted.org/releases/${MY_PN:0:1}/${MY_PN:1:1}/${MY_PN}/${MY_P}.tar.gz https://fedorahosted.org/releases/${MY_PN:0:1}/${MY_PN:1:1}/${MY_PN}/${MY_P2}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86-macos ~x64-macos"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.8"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i "s:/usr/bin/install:\$\{prefix\}/bin/install:" src/Makefile.in
+}
+
+src_compile() {
+ econf --enable-animation || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodir /usr/share/themes
+ insinto /usr/share/themes
+ doins -r ${WORKDIR}/${MY_P2}/${MY_PN/n/N}
+
+ dodoc AUTHORS ChangeLog CREDITS README TODO
+}
diff --git a/x11-themes/gtk-engines-quartz/Manifest b/x11-themes/gtk-engines-quartz/Manifest
new file mode 100644
index 0000000..1ef48c8
--- /dev/null
+++ b/x11-themes/gtk-engines-quartz/Manifest
@@ -0,0 +1 @@
+EBUILD gtk-engines-quartz-9999.ebuild 800 RMD160 db01d9959a4cb7cd3974ef9562423e935df89024 SHA1 7e2cb051238a8e2ace686b4768827e250522714d SHA256 a8844877044fe6ae869955e3b2c67e867979706b8d87e9310a9843627a7c2d67
diff --git a/x11-themes/gtk-engines-quartz/gtk-engines-quartz-9999.ebuild b/x11-themes/gtk-engines-quartz/gtk-engines-quartz-9999.ebuild
new file mode 100644
index 0000000..18609b6
--- /dev/null
+++ b/x11-themes/gtk-engines-quartz/gtk-engines-quartz-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI="2"
+
+WANT_AUTOMAKE="1.10"
+
+inherit git eutils autotools
+
+DESCRIPTION="Quartz GTK+2 Engine"
+
+HOMEPAGE="http://gtk-quartz.sourceforge.net"
+
+EGIT_REPO_URI="git://github.com/rcaelers/gtk-quartz-engine.git"
+EGIT_BRANCH="master"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86-macos ~x64-macos"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.8"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ elibtoolize
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-maintainer-mode || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}