summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/unity-greeter/files')
-rw-r--r--x11-themes/unity-greeter/files/unity-greeter-12.10.4-fix-at-spi-bus-launcher.patch24
-rw-r--r--x11-themes/unity-greeter/files/unity-greeter-12.10.4-valac-18.patch24
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-themes/unity-greeter/files/unity-greeter-12.10.4-fix-at-spi-bus-launcher.patch b/x11-themes/unity-greeter/files/unity-greeter-12.10.4-fix-at-spi-bus-launcher.patch
new file mode 100644
index 0000000..e5fa454
--- /dev/null
+++ b/x11-themes/unity-greeter/files/unity-greeter-12.10.4-fix-at-spi-bus-launcher.patch
@@ -0,0 +1,24 @@
+diff -Naur unity-greeter-12.10.2/src/unity-greeter.c unity-greeter-12.10.2_2012-09-02T12:44:47+0200/src/unity-greeter.c
+--- unity-greeter-12.10.2/src/unity-greeter.c 2012-08-30 17:11:03.000000000 +0200
++++ unity-greeter-12.10.2_2012-09-02T12:44:47+0200/src/unity-greeter.c 2012-09-02 12:44:35.111888972 +0200
+@@ -1016,7 +1016,7 @@
+ gchar** _tmp2_;
+ gint _tmp2__length1;
+ GPid _tmp3_ = 0;
+- g_shell_parse_argv ("/usr/lib/at-spi2-core/at-spi-bus-launcher --launch-immediately", &_tmp1_, &_tmp0_, &_inner_error_);
++ g_shell_parse_argv ("/usr/libexec/at-spi-bus-launcher --launch-immediately", &_tmp1_, &_tmp0_, &_inner_error_);
+ argv = (_vala_array_free (argv, argv_length1, (GDestroyNotify) g_free), NULL);
+ argv = _tmp0_;
+ argv_length1 = _tmp1_;
+diff -Naur unity-greeter-12.10.2/src/unity-greeter.vala unity-greeter-12.10.2_2012-09-02T12:44:47+0200/src/unity-greeter.vala
+--- unity-greeter-12.10.2/src/unity-greeter.vala 2012-08-30 15:53:02.000000000 +0200
++++ unity-greeter-12.10.2_2012-09-02T12:44:47+0200/src/unity-greeter.vala 2012-09-02 12:44:35.112888971 +0200
+@@ -320,7 +320,7 @@
+ {
+ string[] argv;
+
+- Shell.parse_argv ("/usr/lib/at-spi2-core/at-spi-bus-launcher --launch-immediately", out argv);
++ Shell.parse_argv ("/usr/libexec/at-spi-bus-launcher --launch-immediately", out argv);
+ Process.spawn_async (null,
+ argv,
+ null,
diff --git a/x11-themes/unity-greeter/files/unity-greeter-12.10.4-valac-18.patch b/x11-themes/unity-greeter/files/unity-greeter-12.10.4-valac-18.patch
new file mode 100644
index 0000000..4476bf3
--- /dev/null
+++ b/x11-themes/unity-greeter/files/unity-greeter-12.10.4-valac-18.patch
@@ -0,0 +1,24 @@
+diff -Naur unity-greeter-12.10.2/configure unity-greeter-12.10.2.new/configure
+--- unity-greeter-12.10.2/configure 2012-08-30 18:21:17.000000000 +0200
++++ unity-greeter-12.10.2.new/configure 2012-09-02 14:14:01.695534478 +0200
+@@ -3638,7 +3638,7 @@
+ fi
+
+
+-for ac_prog in valac-0.16 valac
++for ac_prog in valac-0.18 valac
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+ set dummy $ac_prog; ac_word=$2
+diff -Naur unity-greeter-12.10.2/configure.ac unity-greeter-12.10.2.new/configure.ac
+--- unity-greeter-12.10.2/configure.ac 2012-08-30 18:20:37.000000000 +0200
++++ unity-greeter-12.10.2.new/configure.ac 2012-09-02 14:14:01.695534478 +0200
+@@ -6,7 +6,7 @@
+ AC_CONFIG_MACRO_DIR(m4)
+ AM_INIT_AUTOMAKE
+ AM_PROG_CC_C_O
+-UG_PROG_VALAC([valac-0.16 valac], [0.15.1])
++UG_PROG_VALAC([valac-0.18 valac], [0.15.1])
+ AM_CONFIG_HEADER(config.h)
+ AM_MAINTAINER_MODE
+ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES(yes)])