summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Sanda <ps@twin.jikos.cz>2012-01-21 21:30:33 +0100
committerPavel Sanda <ps@twin.jikos.cz>2012-01-21 21:30:33 +0100
commit9b9b325d36fb5f1d98400baafe4cd95112f12815 (patch)
tree88f35d36e590d6ced554bc0ab2aef2020a14ffc9 /app-office/lyx
parentesmska: switch to virtual java deps (diff)
downloadrebutia-9b9b325d36fb5f1d98400baafe4cd95112f12815.tar.gz
rebutia-9b9b325d36fb5f1d98400baafe4cd95112f12815.tar.bz2
rebutia-9b9b325d36fb5f1d98400baafe4cd95112f12815.zip
lyx 2 needs new python patch
Diffstat (limited to 'app-office/lyx')
-rw-r--r--app-office/lyx/Manifest3
-rw-r--r--app-office/lyx/files/2.0.3-python.patch26
-rw-r--r--app-office/lyx/lyx-2.0.9999.ebuild2
3 files changed, 29 insertions, 2 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index fa5f2a4..18e1051 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -1,5 +1,6 @@
AUX 1.6.7-python.patch 906 RMD160 74a2f14445d6b011fe04d06f3bd6710d36ab6351 SHA1 a9bc180553105b61767a82280e211a2c187cfbd4 SHA256 ad4ebb8d3837536eea869e15b3759840a1153d64d74b744e956ce9bdf5e5651d
+AUX 2.0.3-python.patch 1036 RMD160 1fdf43487cb67e61b02387834402e9618de87082 SHA1 834ac9383503078c6e9d54610056704b7c9d23c0 SHA256 954f96dab553024fb128924c7ba3d70a91946f6909d203ee0902d6ec8740ded8
AUX lyx-1.5.0-gentoo.patch 1298 RMD160 69b7ce68234e7f5c2fee708944267f1974aa10d0 SHA1 16c3e6f846c55c3eb5fd9d7da1247a3429efa7a4 SHA256 36be1ea2577cce270319a7a3b4bed92e5925c0e974edda8729bda2179ac8ffe2
AUX lyx.desktop 215 RMD160 13192f0f4e84e870565a3daff7d46c56954ed0fe SHA1 f72f3ff17a3a1b84cbb0aaf12c9e75387879a420 SHA256 b0ffd201e0a2e0cb39a52aadb9921e86fbb31c8d3cac04526371d6606246898c
EBUILD lyx-1.6.9999.ebuild 4197 RMD160 1fb05dc360e08c8033a3957d27c4db58b31901fe SHA1 895061e60ef59ac85f787fa5e4c1892588124276 SHA256 5c79ce22e68b93cc470f7c4aab4b35e2e5e9bb45db6ae3e10c12869c9f77262f
-EBUILD lyx-2.0.9999.ebuild 4608 RMD160 0c37eca4d03b54e15bc14b09b326f10880b99654 SHA1 46ef4d064b7a321dd31bc26eb32bcbc2e68a38dc SHA256 eb2bc88053baa598310e0eeea02da1d0d871879a28e6a0e4e95504f3b1e28e36
+EBUILD lyx-2.0.9999.ebuild 4608 RMD160 fc41d483ac72a1e8574e188076592cf53251ad8e SHA1 e03b461d2c504c6e4b9fac8ede29eac7b0627143 SHA256 282405a610d298e2fc0e60d3eb8211203d653db9d7a43ec6ae04c8d147dec396
diff --git a/app-office/lyx/files/2.0.3-python.patch b/app-office/lyx/files/2.0.3-python.patch
new file mode 100644
index 0000000..e12f66a
--- /dev/null
+++ b/app-office/lyx/files/2.0.3-python.patch
@@ -0,0 +1,26 @@
+diff --git a/src/graphics/GraphicsConverter.cpp b/src/graphics/GraphicsConverter.cpp
+index 97c4f68..8f05e62 100644
+--- a/src/graphics/GraphicsConverter.cpp
++++ b/src/graphics/GraphicsConverter.cpp
+@@ -262,7 +262,7 @@ static void build_script(FileName const & from_file,
+ LYXERR(Debug::GRAPHICS, "build_script ... ");
+ typedef Graph::EdgePath EdgePath;
+
+- script << "#!/usr/bin/env python\n"
++ script << "#!/usr/bin/env python2\n"
+ "# -*- coding: utf-8 -*-\n"
+ "import os, shutil, sys\n\n"
+ "def unlinkNoThrow(file):\n"
+diff --git a/src/support/os.cpp b/src/support/os.cpp
+index f36331c..02f5a93 100644
+--- a/src/support/os.cpp
++++ b/src/support/os.cpp
+@@ -57,7 +57,7 @@ static string const python2(string const & binary, bool verbose = false)
+ string const python()
+ {
+ // Check whether the first python in PATH is the right one.
+- static string command = python2("python -tt");
++ static string command = python2("python2 -tt");
+
+ if (command.empty()) {
+ // It was not, so check whether we can find it elsewhere in
diff --git a/app-office/lyx/lyx-2.0.9999.ebuild b/app-office/lyx/lyx-2.0.9999.ebuild
index fd41530..47cc629 100644
--- a/app-office/lyx/lyx-2.0.9999.ebuild
+++ b/app-office/lyx/lyx-2.0.9999.ebuild
@@ -104,7 +104,7 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/1.6.7-python.patch
+ epatch "${FILESDIR}"/2.0.3-python.patch
echo "#!/bin/sh" > config/py-compile
sed "s:python -tt:$(PYTHON) -tt:g" -i lib/configure.py || die
}