summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/ginn')
-rw-r--r--x11-apps/ginn/Manifest3
-rw-r--r--x11-apps/ginn/files/ginn-0.2.5-fix_configure.ac.patch11
-rw-r--r--x11-apps/ginn/ginn-0.2.5.ebuild38
3 files changed, 52 insertions, 0 deletions
diff --git a/x11-apps/ginn/Manifest b/x11-apps/ginn/Manifest
index 49c8d34..5ce8e29 100644
--- a/x11-apps/ginn/Manifest
+++ b/x11-apps/ginn/Manifest
@@ -1,2 +1,5 @@
+AUX ginn-0.2.5-fix_configure.ac.patch 422 RMD160 4aaaff7d4f7696ee6b4c432ab5186c9279649191 SHA1 22472843d0e3466b900fe56352a0c06314f235d5 SHA256 82ed427940bd00b1a53d7bc72d73a9453874df431acb98358b679c06eb8f34c3
DIST ginn-0.2.4.tar.gz 310648 RMD160 f32c016d9edfa19173ce7e3a3a2fc1294b22351b SHA1 68027da2f37ce8c0794931265364321440440324 SHA256 44e64f81ade40fa8b094b69a51ad80fcc1c69407486cecd6b4e27a6aa91c9745
+DIST ginn-0.2.5.tar.gz 310444 RMD160 6acec2bc5b3068737c4b735fca97fd7208623709 SHA1 ce20fbad4dd07859f6c7d27989b4b4fa714d5b1e SHA256 2b40ad3f7c8dd0681175431b34c46fe9ef66f7ab8f90721d6e83f28d10dd68bf
EBUILD ginn-0.2.4.ebuild 541 RMD160 630e482ebd597d55ca44860f64f953276f1ee446 SHA1 9323198ec29e04753fd443d777da84e43e064958 SHA256 ae60e49e3fa7d746a731030a2441ba816c35772fa5f120ee140beef339ea8f2d
+EBUILD ginn-0.2.5.ebuild 658 RMD160 cb5db1ef8874c9b4804d1547bb19dabe6a30f2fc SHA1 16f9a95fa1b346d68e24b47583490a07697125d7 SHA256 46398e1a555cca8fb5cb9a504353345fcccdad858c635e19a9f42a7bb4c9626e
diff --git a/x11-apps/ginn/files/ginn-0.2.5-fix_configure.ac.patch b/x11-apps/ginn/files/ginn-0.2.5-fix_configure.ac.patch
new file mode 100644
index 0000000..dbd247e
--- /dev/null
+++ b/x11-apps/ginn/files/ginn-0.2.5-fix_configure.ac.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2011-10-29 19:55:36.599930704 +0200
++++ b/configure.ac 2011-05-17 14:38:31.000000000 +0200
+@@ -26,7 +26,7 @@
+ PKG_CHECK_MODULES([X11], [x11 >= 1.3.3])
+ PKG_CHECK_MODULES([XML2], [libxml-2.0 >= 2.7.7])
+ PKG_CHECK_MODULES([XTST], [xtst >= 1.1.0])
++PKG_CHECK_MODULES([BAMF], [libbamf3 >= 0.2.53])
+-PKG_CHECK_MODULES([BAMF], [libbamf >= 0.2.53])
+
+ AC_CONFIG_FILES([Makefile
+ src/Makefile
diff --git a/x11-apps/ginn/ginn-0.2.5.ebuild b/x11-apps/ginn/ginn-0.2.5.ebuild
new file mode 100644
index 0000000..c638b94
--- /dev/null
+++ b/x11-apps/ginn/ginn-0.2.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit autotools
+
+DESCRIPTION="Gesture Injector: No-GEIS, No-Toolkits"
+SRC_URI="http://launchpad.net/ginn/0.x/${PV}/+download/ginn-${PV}.tar.gz"
+HOMEPAGE="http://launchpad.net/canonical-multitouch/ginn"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="LGPL-3"
+IUSE=""
+
+
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ x11-libs/utouch-geis
+ >=x11-libs/bamf-0.2.104
+ "
+
+src_prepare() {
+ epatch "${FILESDIR}/ginn-0.2.5-fix_configure.ac.patch"
+ eautoconf
+}
+
+src_compile() {
+ econf
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+}