summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-evdev/xf86-input-evdev-2.6.0-r2.ebuild')
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.6.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.6.0-r2.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.6.0-r2.ebuild
new file mode 100644
index 0000000..3162c09
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.6.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.6.0.ebuild,v 1.7 2011/03/05 18:09:14 xarthisius Exp $
+
+EAPI=3
+XORG_EAUTORECONF=yes
+
+inherit xorg-2
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86"
+IUSE="utouch"
+
+RDEPEND=">=x11-base/xorg-server-1.6.3"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6
+ x11-proto/inputproto
+ x11-proto/xproto
+ x11-libs/mtdev"
+
+src_prepare() {
+ if use utouch ; then
+ epatch "${FILESDIR}/xf86-input-evdev-xi2.1.patch"
+ epatch "${FILESDIR}/xf86-input-evdev-gestures.patch"
+ epatch "${FILESDIR}/xf86-input-evdev-fix_valuator_procimity_handling.patch"
+ fi
+
+ xorg-2_src_prepare
+}
+
+src_install() {
+ xorg-2_src_install
+}
+
+