summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2011-01-16 21:09:56 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2011-01-16 21:09:56 +0100
commit0fbbc1e085f3254ff84823c0419243b21c381d33 (patch)
tree774b8c1e7a9b98e36b64057e843a5ce0840b4a7a
parentAdd a patch from Keruspe to temporary fix a segfault (diff)
downloadsardemff7-0fbbc1e085f3254ff84823c0419243b21c381d33.tar.gz
sardemff7-0fbbc1e085f3254ff84823c0419243b21c381d33.tar.bz2
sardemff7-0fbbc1e085f3254ff84823c0419243b21c381d33.zip
Update the cairo fixup from Mozilla overlay
-rw-r--r--net-libs/xulrunner/Manifest2
-rw-r--r--net-libs/xulrunner/files/system-cairo-fixup.patch11
2 files changed, 9 insertions, 4 deletions
diff --git a/net-libs/xulrunner/Manifest b/net-libs/xulrunner/Manifest
index f3a6bcf..106bd0e 100644
--- a/net-libs/xulrunner/Manifest
+++ b/net-libs/xulrunner/Manifest
@@ -1,6 +1,6 @@
AUX gentoo-specific.patch 2957 RMD160 684dc2176769a56c2b1c206b59f999cd44d99c45 SHA1 35ff8e325e45b5384a404a4f99b12fdba9d5e0f3 SHA256 23d981e48a5308dd11ce2fc831071d138d54717bff9cb546dfc5467b0f4204c7
AUX keruspe-fix-segfault.patch 475 RMD160 d10df2f0b7c4273f8654d12b3920897028949bd7 SHA1 129133176e72b4cb2b17ba577e1061f53f6b1b40 SHA256 4b8f77c1ebadc9163abb8acebe7d26153f5dc7468e27c8f1c341484c711e2769
AUX libnotify-0.7-fix.patch 1209 RMD160 07615cde8fb0dbd9876635d0b437943df3f4879c SHA1 16caf17a571b4ede370fc20ffffc87179afd3cd3 SHA256 80dbd0906b45cd42b0fda0ec6fa48daf04cb5f85a14e164287565ffa4e486642
-AUX system-cairo-fixup.patch 3146 RMD160 c1e15592ab30360cb1b528e174674ace83cf60d1 SHA1 4f5687a84d3a7687242a34a713b28272788feb5e SHA256 376292d4be0f0b3e760a6d30c1cce240a176774cd5a4f62e01ebd7d30f16bf56
+AUX system-cairo-fixup.patch 3300 RMD160 3e6888863f990787f7e59eb8c9afcef546fe1e78 SHA1 1208120150b5bfbaf7c77d4521bab89e34a0dc97 SHA256 f6e47cc92dd032f2bfbd830953e55697c875e0361c08c2575b18694c7f8202ae
AUX xulrunner-default-prefs.js 709 RMD160 a4d062f75c17552545267ec3fe2f6b54073dafbd SHA1 580128e9edf8021fdbbca2c91abf63cb83bab2c7 SHA256 e6850b0a22f7d3889b49ec4a79a3c4d3d077edd98c8f0ffdc26e30bc70bb4b09
EBUILD xulrunner-9999.ebuild 7451 RMD160 cbd069bb9425ac4a6648192445fd65d0757d4b00 SHA1 0c9b6fe5c2d4badcbc8291274beb6dfa3c032a9b SHA256 2def77a4a3681b1387cfe8086f6e4dde1a460da5ef710f22f16b178bef690f76
diff --git a/net-libs/xulrunner/files/system-cairo-fixup.patch b/net-libs/xulrunner/files/system-cairo-fixup.patch
index b66d504..ac43a3f 100644
--- a/net-libs/xulrunner/files/system-cairo-fixup.patch
+++ b/net-libs/xulrunner/files/system-cairo-fixup.patch
@@ -47,16 +47,18 @@ diff --git a/gfx/thebes/gfxASurface.cpp b/gfx/thebes/gfxASurface.cpp
{
if (!mSurfaceValid)
return (gfxSurfaceType)-1;
-@@ -432,26 +434,32 @@ gfxASurface::FormatFromContent(gfxASurfa
+@@ -430,28 +432,34 @@ gfxASurface::FormatFromContent(gfxASurfa
+ default:
+ return ImageFormatRGB24;
}
}
void
gfxASurface::SetSubpixelAntialiasingEnabled(PRBool aEnabled)
{
++#ifdef MOZ_TREE_CAIRO
if (!mSurfaceValid)
return;
-+#ifdef MOZ_TREE_CAIRO
cairo_surface_set_subpixel_antialiasing(mSurface,
aEnabled ? CAIRO_SUBPIXEL_ANTIALIASING_ENABLED : CAIRO_SUBPIXEL_ANTIALIASING_DISABLED);
+#endif
@@ -83,7 +85,7 @@ diff --git a/gfx/thebes/gfxASurface.cpp b/gfx/thebes/gfxASurface.cpp
diff --git a/gfx/thebes/gfxTeeSurface.cpp b/gfx/thebes/gfxTeeSurface.cpp
--- a/gfx/thebes/gfxTeeSurface.cpp
+++ b/gfx/thebes/gfxTeeSurface.cpp
-@@ -32,17 +32,21 @@
+@@ -32,17 +32,24 @@
* and other provisions required by the GPL or the LGPL. If you do not delete
* the provisions above, a recipient may use your version of this file under
* the terms of any one of the MPL, the GPL or the LGPL.
@@ -92,6 +94,9 @@ diff --git a/gfx/thebes/gfxTeeSurface.cpp b/gfx/thebes/gfxTeeSurface.cpp
#include "gfxTeeSurface.h"
++/* Once cairo in tree is update ensure we remove the ifdef
++ and just include cairo-tee.h
++*/
+#ifdef MOZ_TREE_CAIRO
#include "cairo.h"
+#else