aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2010-11-04 23:02:03 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2010-11-04 23:02:03 +0100
commit318843e14246d3bf3c6771f7fa8fe48af595e190 (patch)
treebacdb09f57c3db4a4fe507c0f7f62bc1ff6629bd
parentdev-util/geany: Patch merged upstream (diff)
downloadsardemff7-318843e14246d3bf3c6771f7fa8fe48af595e190.tar.gz
sardemff7-318843e14246d3bf3c6771f7fa8fe48af595e190.tar.bz2
sardemff7-318843e14246d3bf3c6771f7fa8fe48af595e190.zip
games-emulation/sdlmess: Merged upstream
-rw-r--r--games-emulation/sdlmess/Manifest3
-rw-r--r--games-emulation/sdlmess/files/pce.patch99
-rw-r--r--games-emulation/sdlmess/sdlmess-9999.ebuild1
3 files changed, 1 insertions, 102 deletions
diff --git a/games-emulation/sdlmess/Manifest b/games-emulation/sdlmess/Manifest
index 7c9d642..e3a650b 100644
--- a/games-emulation/sdlmess/Manifest
+++ b/games-emulation/sdlmess/Manifest
@@ -1,4 +1,3 @@
AUX mess.ini.in 6436 RMD160 21963b1485990d63f49a8c21b717ae4fb2a97973 SHA1 fe361e09cdb88b8446f2ea244b08b738bdd18c53 SHA256 7011d36654b763e2b29fc3b0fcd66ef0497b75bf197e7af0b77a66bbc8224bfc
-AUX pce.patch 4744 RMD160 3a17aa32773f2ecc64e7509d6f84fef2c83b1022 SHA1 a87eda86e05c86d33fac703607237f21b9a95f97 SHA256 7ac5db4ee2155ccc8d92bb140fe1870e8c66e248b66160a8c747aca9774b1be4
AUX vector.ini.in 119 RMD160 ca72c401ea186bc04da6db12667b0c8e66367c8c SHA1 c805e53b04c3e0df55c564b4863e9d987ffd992b SHA256 c65c4fae86c3a36b877d12c19c81a233ec496a1888380dfcb3171e43f7ad1b16
-EBUILD sdlmess-9999.ebuild 2652 RMD160 71139c6de22b26743c9b27937ab5355cebf94bdc SHA1 eb6040079620507dc1c8fdc32581305783441f97 SHA256 e76d8fdd6b942a10048e5e8e7c8d5a2e811d9f25f95d09b149ec6537f133de35
+EBUILD sdlmess-9999.ebuild 2620 RMD160 33e8874151de399fb28b9880f2c577cfa57a9523 SHA1 67daef7505a8210dc6a235fcb3789425f9c6bbd2 SHA256 d2a9eca63d4e2b7ef4cc3e09721b7fc28f2d441495ccbdc43dab528bad865f69
diff --git a/games-emulation/sdlmess/files/pce.patch b/games-emulation/sdlmess/files/pce.patch
deleted file mode 100644
index c99de2a..0000000
--- a/games-emulation/sdlmess/files/pce.patch
+++ /dev/null
@@ -1,99 +0,0 @@
---- a/src/mess/machine/pce.c 2010-10-18 21:33:23.776000007 +0200
-+++ b/src/mess/machine/pce.c 2010-10-18 21:32:42.540000006 +0200
-@@ -1306,7 +1306,7 @@
- {
- pce_cd.cdda_volume = 0.0;
- cdda_set_volume(machine->device("cdda"), 0.0);
-- timer_adjust_oneshot(pce_cd.cdda_fadeout_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.cdda_fadeout_timer, attotime_never, 0);
- }
- else
- {
-@@ -1323,7 +1323,7 @@
- {
- pce_cd.cdda_volume = 100.0;
- cdda_set_volume(machine->device("cdda"), 100.0);
-- timer_adjust_oneshot(pce_cd.cdda_fadein_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.cdda_fadein_timer, attotime_never, 0);
- }
- else
- {
-@@ -1340,7 +1340,7 @@
- {
- pce_cd.adpcm_volume = 0.0;
- msm5205_set_volume(machine->device("msm5205"), 0.0);
-- timer_adjust_oneshot(pce_cd.adpcm_fadeout_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.adpcm_fadeout_timer, attotime_never, 0);
- }
- else
- {
-@@ -1357,7 +1357,7 @@
- {
- pce_cd.adpcm_volume = 100.0;
- msm5205_set_volume(machine->device("msm5205"), 100.0);
-- timer_adjust_oneshot(pce_cd.adpcm_fadein_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.adpcm_fadein_timer, attotime_never, 0);
- }
- else
- {
-@@ -1496,49 +1496,49 @@
- timer_adjust_oneshot(pce_cd.cdda_fadein_timer, ATTOTIME_IN_USEC(100), 100);
- pce_cd.adpcm_volume = 0.0;
- timer_adjust_oneshot(pce_cd.adpcm_fadein_timer, ATTOTIME_IN_USEC(100), 100);
-- timer_adjust_oneshot(pce_cd.cdda_fadeout_timer, attotime_never, NULL);
-- timer_adjust_oneshot(pce_cd.adpcm_fadeout_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.cdda_fadeout_timer, attotime_never, 0);
-+ timer_adjust_oneshot(pce_cd.adpcm_fadeout_timer, attotime_never, 0);
- break;
- case 0x01: //CD-DA enable (100 msecs)
- pce_cd.cdda_volume = 0.0;
- timer_adjust_oneshot(pce_cd.cdda_fadein_timer, ATTOTIME_IN_USEC(100), 100);
-- timer_adjust_oneshot(pce_cd.cdda_fadeout_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.cdda_fadeout_timer, attotime_never, 0);
- break;
- case 0x08: //CD-DA short (1500 msecs) fade out / ADPCM enable
- pce_cd.cdda_volume = 100.0;
- timer_adjust_oneshot(pce_cd.cdda_fadeout_timer, ATTOTIME_IN_USEC(1500), 1500);
- pce_cd.adpcm_volume = 0.0;
- timer_adjust_oneshot(pce_cd.adpcm_fadein_timer, ATTOTIME_IN_USEC(100), 100);
-- timer_adjust_oneshot(pce_cd.cdda_fadein_timer, attotime_never, NULL);
-- timer_adjust_oneshot(pce_cd.adpcm_fadeout_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.cdda_fadein_timer, attotime_never, 0);
-+ timer_adjust_oneshot(pce_cd.adpcm_fadeout_timer, attotime_never, 0);
- break;
- case 0x09: //CD-DA long (5000 msecs) fade out
- pce_cd.cdda_volume = 100.0;
- timer_adjust_oneshot(pce_cd.cdda_fadeout_timer, ATTOTIME_IN_USEC(5000), 5000);
-- timer_adjust_oneshot(pce_cd.cdda_fadein_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.cdda_fadein_timer, attotime_never, 0);
- break;
- case 0x0a: //ADPCM long (5000 msecs) fade out
- pce_cd.adpcm_volume = 100.0;
- timer_adjust_oneshot(pce_cd.adpcm_fadeout_timer, ATTOTIME_IN_USEC(5000), 5000);
-- timer_adjust_oneshot(pce_cd.adpcm_fadein_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.adpcm_fadein_timer, attotime_never, 0);
- break;
- case 0x0c: //CD-DA short (1500 msecs) fade out / ADPCM enable
- pce_cd.cdda_volume = 100.0;
- timer_adjust_oneshot(pce_cd.cdda_fadeout_timer, ATTOTIME_IN_USEC(1500), 1500);
- pce_cd.adpcm_volume = 0.0;
- timer_adjust_oneshot(pce_cd.adpcm_fadein_timer, ATTOTIME_IN_USEC(100), 100);
-- timer_adjust_oneshot(pce_cd.cdda_fadein_timer, attotime_never, NULL);
-- timer_adjust_oneshot(pce_cd.adpcm_fadeout_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.cdda_fadein_timer, attotime_never, 0);
-+ timer_adjust_oneshot(pce_cd.adpcm_fadeout_timer, attotime_never, 0);
- break;
- case 0x0d: //CD-DA short (1500 msecs) fade out
- pce_cd.cdda_volume = 100.0;
- timer_adjust_oneshot(pce_cd.cdda_fadeout_timer, ATTOTIME_IN_USEC(1500), 1500);
-- timer_adjust_oneshot(pce_cd.cdda_fadein_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.cdda_fadein_timer, attotime_never, 0);
- break;
- case 0x0e: //ADPCM short (1500 msecs) fade out
- pce_cd.adpcm_volume = 100.0;
- timer_adjust_oneshot(pce_cd.adpcm_fadeout_timer, ATTOTIME_IN_USEC(1500), 1500);
-- timer_adjust_oneshot(pce_cd.adpcm_fadein_timer, attotime_never, NULL);
-+ timer_adjust_oneshot(pce_cd.adpcm_fadein_timer, attotime_never, 0);
- break;
- default:
- popmessage("CD-DA / ADPCM Fade effect mode %02x, contact MESSdev",data & 0x0f);
diff --git a/games-emulation/sdlmess/sdlmess-9999.ebuild b/games-emulation/sdlmess/sdlmess-9999.ebuild
index a568633..0e5c72c 100644
--- a/games-emulation/sdlmess/sdlmess-9999.ebuild
+++ b/games-emulation/sdlmess/sdlmess-9999.ebuild
@@ -44,7 +44,6 @@ src_prepare() {
-e '/^CCOMFLAGS =$/s:$:'"${CFLAGS}:" \
makefile \
|| die "sed failed"
- epatch "${FILESDIR}"/pce.patch
}
src_compile() {