summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2011-01-26 22:35:54 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2011-01-26 22:35:54 +0100
commit5e26f74ebaf695b8f614556565f39765edb2ecd8 (patch)
treea191e3bed9e5977d18e526282b70f0de35d7f65e /www-client/firefox/firefox-9999.ebuild
parentTypso (diff)
downloadsardemff7-5e26f74ebaf695b8f614556565f39765edb2ecd8.tar.gz
sardemff7-5e26f74ebaf695b8f614556565f39765edb2ecd8.tar.bz2
sardemff7-5e26f74ebaf695b8f614556565f39765edb2ecd8.zip
Create a mozilla-scm eclass to prepare the future thunderbird-9999
Diffstat (limited to 'www-client/firefox/firefox-9999.ebuild')
-rw-r--r--www-client/firefox/firefox-9999.ebuild87
1 files changed, 7 insertions, 80 deletions
diff --git a/www-client/firefox/firefox-9999.ebuild b/www-client/firefox/firefox-9999.ebuild
index 42985f3..c446037 100644
--- a/www-client/firefox/firefox-9999.ebuild
+++ b/www-client/firefox/firefox-9999.ebuild
@@ -3,19 +3,8 @@
# $Header: $
EAPI="3"
-WANT_AUTOCONF="2.1"
-: ${EHG_QUIET:=OFF} # geeks prefer verbose stuff
-inherit flag-o-matic toolchain-funcs eutils prefix mozconfig-3 makeedit multilib pax-utils autotools python speed-mercurial fdo-mime mozextension
-
-EHG_REPO_URI="http://hg.mozilla.org/mozilla-central/"
-EHG_PROJECT="xulrunner"
-# It avoids having some funny changesets that breaks all because
-# the xulrunner build time and hg clone time are quite long
-EHG_OFFLINE=y
-
-MAJ_XUL_PV="2.0"
-MAJ_FF_PV="4.0"
+inherit mozilla-scm
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="http://www.mozilla.com/firefox"
@@ -23,46 +12,17 @@ HOMEPAGE="http://www.mozilla.com/firefox"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE="+alsa +ipc libnotify system-sqlite +webm wifi"
-
-RDEPEND="
- >=sys-devel/binutils-2.16.1
- >=dev-libs/nss-3.12.9
- >=dev-libs/nspr-4.8.7
- >=app-text/hunspell-1.2
- >=x11-libs/cairo-1.8.8[X]
- x11-libs/pango[X]
- media-libs/libpng[apng]
- webm? ( media-libs/libvpx )
- alsa? ( media-libs/alsa-lib )
- libnotify? ( >=x11-libs/libnotify-0.4 )
- system-sqlite? ( >=dev-db/sqlite-3.7.4[fts3,secure-delete,unlock-notify] )
- wifi? ( net-wireless/wireless-tools )
- ~net-libs/xulrunner-9999[wifi=,libnotify=,system-sqlite=,webm=]"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- webm? ( dev-lang/yasm )"
+IUSE=""
+
+DEPEND="
+ webm? ( dev-lang/yasm )
+ "
SRC_URI=""
S="${WORKDIR}/mozilla-central"
QA_PRESTRIPPED="usr/$(get_libdir)/${PN}/firefox"
-pkg_setup() {
- # Ensure we always build with C locale.
- export LANG="C"
- export LC_ALL="C"
- export LC_MESSAGES="C"
- export LC_CTYPE="C"
-
- elog "You are enabling official branding. You may not redistribute this build"
- elog "to any users on your network or the internet. Doing so puts yourself into"
- elog "a legal problem with Mozilla Foundation"
-
- python_set_active_version 2
-}
-
src_prepare() {
# Gentoo specific stuff
epatch "${FILESDIR}"/gentoo-specific.patch
@@ -89,7 +49,6 @@ src_prepare() {
src_configure() {
MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
- MEXTENSIONS="default"
####################################
#
@@ -178,33 +137,11 @@ src_configure() {
CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" PYTHON="$(PYTHON)" econf
}
-src_compile() {
- # Should the build use multiprocessing? Not enabled by default, as it tends to break
- [ "${WANT_MP}" = "true" ] && jobs=${MAKEOPTS} || jobs="-j1"
- emake ${jobs} || die
-}
-
src_install() {
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- emake DESTDIR="${D}" install || die "emake install failed"
-
- # Install icon and .desktop for menu entry
- newicon "${S}"/other-licenses/branding/firefox/content/icon48.png ${PN}-icon.png
- newmenu "${FILESDIR}"/${PN}.desktop \
- ${PN}.desktop
-
- # Add StartupNotify=true bug 237317
- if use startup-notification ; then
- echo "StartupNotify=true" >> "${ED}"/usr/share/applications/${PN}.desktop
- fi
+ mozilla-scm_src_install
pax-mark m "${ED}"/${MOZILLA_FIVE_HOME}/firefox
- # Enable very specific settings not inherited from xulrunner
- cp "${FILESDIR}"/firefox-default-prefs.js \
- "${ED}/${MOZILLA_FIVE_HOME}/defaults/preferences/all-gentoo.js" || \
- die "failed to cp firefox-default-prefs.js"
# Plugins dir
dosym ../nsbrowser/plugins "${MOZILLA_FIVE_HOME}"/plugins \
@@ -215,13 +152,3 @@ src_install() {
-i "${ED}/${MOZILLA_FIVE_HOME}/application.ini" || \
die "sparc sed failed"; }
}
-
-pkg_postinst() {
- ewarn "All the packages built against ${PN} won't compile,"
- ewarn "any package that fails to build warrants a bug report."
- elog
- einfo "You should build xulrunner first to update the mercurial repository"
-
- # Update mimedb for the new .desktop file
- fdo-mime_desktop_database_update
-}