aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/purple-presence/purple-presence-0.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/purple-presence/purple-presence-0.6.ebuild b/x11-plugins/purple-presence/purple-presence-0.6.ebuild
new file mode 100644
index 0000000..edf086f
--- /dev/null
+++ b/x11-plugins/purple-presence/purple-presence-0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v3
+# $Header: $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Provides GnomeSession Presence status support to Pidgin"
+HOMEPAGE="https://sardemff7.github.com/"
+SRC_URI="https://github.com/downloads/sardemff7/Purple-Presence/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls"
+
+RDEPEND=">=net-im/pidgin-2.4.0
+ >=dev-libs/glib-2.26.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+ find "${ED}" -name '*.la' -exec rm -f '{}' + || die
+ dodoc AUTHORS ChangeLog NEWS README
+}
+