aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/firefox/Manifest6
-rw-r--r--www-client/firefox/files/gentoo-specific.patch166
-rw-r--r--www-client/firefox/firefox-9999.ebuild6
3 files changed, 60 insertions, 118 deletions
diff --git a/www-client/firefox/Manifest b/www-client/firefox/Manifest
index eec50e4..4ecde9a 100644
--- a/www-client/firefox/Manifest
+++ b/www-client/firefox/Manifest
@@ -1,4 +1,4 @@
-AUX firefox-default-prefs.js 95 RMD160 805cdfec6fb31c224322cb71125547ad7a515f49 SHA1 7fab69d85b12a9f1b0c87fbb1821bdafd7485ac9 SHA256 8bc4cb870bc402db1f20b135a689f8c5dbfa5de8f1755b1926198d627c12c5f1
+AUX default-prefs.js 95 RMD160 805cdfec6fb31c224322cb71125547ad7a515f49 SHA1 7fab69d85b12a9f1b0c87fbb1821bdafd7485ac9 SHA256 8bc4cb870bc402db1f20b135a689f8c5dbfa5de8f1755b1926198d627c12c5f1
AUX firefox.desktop 255 RMD160 4ef1cf548f11057274620b82f0728958a3424bea SHA1 6a440f817072fb60516c1a1d999dffb6d3fa1583 SHA256 9bf6e1264d986c68d64831d166ed6b506bff6df8b56d21bfc166aee09cbc753f
-AUX gentoo-specific.patch 5781 RMD160 d8e676c7ef75d6ae81dad286d02fb841e162962a SHA1 f77b09a5ae616ca0e58eddb26307b86438c70b2b SHA256 78e54d73b7c6096ae4ab680bf87df9491b501f7417b0c9120fff79e49067eac9
-EBUILD firefox-9999.ebuild 6916 RMD160 08621cc2209a4582227d0cf0de5b540986bfee89 SHA1 0fb9e9f9945ffd38aed63bd3a8fb29ebd4d47f23 SHA256 92993c598a816983f65d2539a3eccc0a7d7f40f81590584994820d51bbce9260
+AUX gentoo-specific.patch 3937 RMD160 d167b98c03ff88d955e865aee78203d396620cf7 SHA1 92a372a945734b737ed2d4b534fc8a6ef9e39bbf SHA256 dd6115dcca2972d637f966c6c7faef6d19d8e2622e3c44a0950e98c8f18ec747
+EBUILD firefox-9999.ebuild 4390 RMD160 b64ce84e762da164aa6d28344436a2015420a6d0 SHA1 184bdcda3eadb5665cb1fcc02e4d9d0bb3f4bc4b SHA256 cca350d2e9dfe8495a4295d884ee9e31e6e7728652f17573611d4ba75f93eae8
diff --git a/www-client/firefox/files/gentoo-specific.patch b/www-client/firefox/files/gentoo-specific.patch
index 0b49a90..ab27d4a 100644
--- a/www-client/firefox/files/gentoo-specific.patch
+++ b/www-client/firefox/files/gentoo-specific.patch
@@ -1,12 +1,39 @@
-diff --git a/extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java b/extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java
---- a/extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java
-+++ b/extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java
-@@ -465,18 +465,18 @@ IXPCOMError {
- grePath = getPathFromConfigFile(env, aVersions, aProperties);
- if (grePath != null) {
- return grePath;
- }
- }
+diff -r ab0dc35174fb browser/components/preferences/advanced.js
+--- a/browser/components/preferences/advanced.js Tue Feb 15 23:54:37 2011 -0800
++++ b/browser/components/preferences/advanced.js Wed Feb 16 13:42:47 2011 +0100
+@@ -500,7 +500,7 @@
+ var enabledPref = document.getElementById("app.update.enabled");
+ var enableAppUpdate = document.getElementById("enableAppUpdate");
+
+- enableAppUpdate.disabled = !aus.canCheckForUpdates || enabledPref.locked;
++ enableAppUpdate.disabled = true;
+ },
+
+ /**
+@@ -515,8 +515,7 @@
+ var updateModeLabel = document.getElementById("updateModeLabel");
+ var updateMode = document.getElementById("updateMode");
+
+- var disable = enabledPref.locked || !enabledPref.value ||
+- autoPref.locked;
++ var disable = true;
+ updateModeLabel.disabled = updateMode.disabled = disable;
+ },
+
+@@ -532,8 +531,7 @@
+
+ var warnIncompatible = document.getElementById("warnIncompatible");
+
+- var disable = enabledPref.locked || !enabledPref.value || autoPref.locked ||
+- !autoPref.value || modePref.locked;
++ var disable = true;
+ warnIncompatible.disabled = disable;
+ },
+
+diff -r ab0dc35174fb extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java
+--- a/extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java Tue Feb 15 23:54:37 2011 -0800
++++ b/extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java Wed Feb 16 13:42:47 2011 +0100
+@@ -470,8 +470,8 @@
final String greUserConfFile = ".gre.config";
final String greUserConfDir = ".gre.d";
@@ -17,21 +44,11 @@ diff --git a/extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java b/e
env = System.getProperty("user.home");
if (env != null) {
- // Look in ~/.gre.config
- grePath = getPathFromConfigFile(env + File.separator + greUserConfFile,
- aVersions, aProperties);
- if (grePath != null) {
- return grePath;
-diff --git a/layout/base/nsPresArena.cpp b/layout/base/nsPresArena.cpp
---- a/layout/base/nsPresArena.cpp
-+++ b/layout/base/nsPresArena.cpp
-@@ -68,16 +68,20 @@
- #define PL_ARENA_CONST_ALIGN_MASK ((PRUword(1) << ALIGN_SHIFT) - 1)
- #include "plarena.h"
-
- #ifdef _WIN32
- # include <windows.h>
- #else
+diff -r ab0dc35174fb layout/base/nsPresArena.cpp
+--- a/layout/base/nsPresArena.cpp Tue Feb 15 23:54:37 2011 -0800
++++ b/layout/base/nsPresArena.cpp Wed Feb 16 13:42:47 2011 +0100
+@@ -73,6 +73,10 @@
+ #elif !defined(__OS2__)
# include <unistd.h>
# include <sys/mman.h>
+# ifdef SOLARIS
@@ -41,20 +58,10 @@ diff --git a/layout/base/nsPresArena.cpp b/layout/base/nsPresArena.cpp
# ifndef MAP_ANON
# ifdef MAP_ANONYMOUS
# define MAP_ANON MAP_ANONYMOUS
- # else
- # error "Don't know how to get anonymous memory"
- # endif
- # endif
- #endif
-diff --git a/xpcom/build/nsXPCOMPrivate.h b/xpcom/build/nsXPCOMPrivate.h
---- a/xpcom/build/nsXPCOMPrivate.h
-+++ b/xpcom/build/nsXPCOMPrivate.h
-@@ -274,18 +274,18 @@ void LogTerm();
- #define GRE_FRAMEWORK_NAME "XUL.framework"
- #define XUL_DLL "XUL"
- #else
- #define XPCOM_SEARCH_KEY "LD_LIBRARY_PATH"
- #define XUL_DLL "libxul"MOZ_DLL_SUFFIX
+diff -r ab0dc35174fb xpcom/build/nsXPCOMPrivate.h
+--- a/xpcom/build/nsXPCOMPrivate.h Tue Feb 15 23:54:37 2011 -0800
++++ b/xpcom/build/nsXPCOMPrivate.h Wed Feb 16 13:42:47 2011 +0100
+@@ -279,8 +279,8 @@
#endif
#define GRE_CONF_NAME ".gre.config"
@@ -65,20 +72,10 @@ diff --git a/xpcom/build/nsXPCOMPrivate.h b/xpcom/build/nsXPCOMPrivate.h
#define GRE_USER_CONF_DIR ".gre.d"
#endif
- #if defined(XP_WIN) || defined(XP_OS2)
- #define XPCOM_FILE_PATH_SEPARATOR "\\"
- #define XPCOM_ENV_PATH_SEPARATOR ";"
- #elif defined(XP_UNIX) || defined(XP_BEOS)
- #define XPCOM_FILE_PATH_SEPARATOR "/"
-diff --git a/xulrunner/app/nsRegisterGREUnix.cpp b/xulrunner/app/nsRegisterGREUnix.cpp
---- a/xulrunner/app/nsRegisterGREUnix.cpp
-+++ b/xulrunner/app/nsRegisterGREUnix.cpp
-@@ -107,17 +107,17 @@ RegisterXULRunner(PRBool aRegisterGlobal
- const GREProperty *aProperties, PRUint32 aPropertiesLen,
- const char *aGREMilestone)
- {
- // Register ourself in /etc/gre.d or ~/.gre.d/ and record what key we created
- // for future unregistration.
+diff -r ab0dc35174fb xulrunner/app/nsRegisterGREUnix.cpp
+--- a/xulrunner/app/nsRegisterGREUnix.cpp Tue Feb 15 23:54:37 2011 -0800
++++ b/xulrunner/app/nsRegisterGREUnix.cpp Wed Feb 16 13:42:47 2011 +0100
+@@ -114,7 +114,7 @@
nsresult rv;
@@ -87,17 +84,7 @@ diff --git a/xulrunner/app/nsRegisterGREUnix.cpp b/xulrunner/app/nsRegisterGREUn
if (!aRegisterGlobally) {
char *home = PR_GetEnv("HOME");
- if (!home || !*home)
- return PR_FALSE;
-
- PR_snprintf(root, MAXPATHLEN, "%s/.gre.d", home);
- }
-@@ -199,17 +199,17 @@ RegisterXULRunner(PRBool aRegisterGlobal
- }
-
- void
- UnregisterXULRunner(PRBool aRegisterGlobally, nsIFile* aLocation,
- const char *aGREMilestone)
+@@ -206,7 +206,7 @@
{
nsresult rv;
@@ -106,20 +93,10 @@ diff --git a/xulrunner/app/nsRegisterGREUnix.cpp b/xulrunner/app/nsRegisterGREUn
if (!aRegisterGlobally) {
char *home = PR_GetEnv("HOME");
- if (!home || !*home)
- return;
-
- PR_snprintf(root, MAXPATHLEN, "%s/.gre.d", home);
- }
-diff --git a/xulrunner/installer/Makefile.in b/xulrunner/installer/Makefile.in
---- a/xulrunner/installer/Makefile.in
-+++ b/xulrunner/installer/Makefile.in
-@@ -68,17 +68,17 @@ INSTALL_SDK = 1
- include $(topsrcdir)/toolkit/mozapps/installer/packager.mk
-
- $(MOZILLA_VERSION).system.conf: $(topsrcdir)/config/milestone.txt Makefile
- printf "[%s]\nGRE_PATH=%s\nxulrunner=true\nabi=%s" \
- $(MOZILLA_VERSION) $(installdir) $(TARGET_XPCOM_ABI)> $@
+diff -r ab0dc35174fb xulrunner/installer/Makefile.in
+--- a/xulrunner/installer/Makefile.in Tue Feb 15 23:54:37 2011 -0800
++++ b/xulrunner/installer/Makefile.in Wed Feb 16 13:42:47 2011 +0100
+@@ -73,7 +73,7 @@
ifndef SKIP_GRE_REGISTRATION
# to register xulrunner per-user, override this with $HOME/.gre.d
@@ -128,38 +105,3 @@ diff --git a/xulrunner/installer/Makefile.in b/xulrunner/installer/Makefile.in
install:: $(MOZILLA_VERSION).system.conf
$(NSINSTALL) -D $(DESTDIR)$(regdir)
- $(SYSINSTALL) $(IFLAGS1) $^ $(DESTDIR)$(regdir)
- endif
-
- # Add pkg-config files to the install:: target
-
---- a/browser/components/preferences/advanced.js 2009-11-24 22:12:34.000000000 -0600
-+++ b/browser/components/preferences/advanced.js 2009-12-02 10:26:18.378458863 -0600
-@@ -408,7 +408,7 @@
- var enabledPref = document.getElementById("app.update.enabled");
- var enableAppUpdate = document.getElementById("enableAppUpdate");
-
-- enableAppUpdate.disabled = !aus.canCheckForUpdates || enabledPref.locked;
-+ enableAppUpdate.disabled = true;
- },
-
- /**
-@@ -423,8 +423,7 @@
- var updateModeLabel = document.getElementById("updateModeLabel");
- var updateMode = document.getElementById("updateMode");
-
-- var disable = enabledPref.locked || !enabledPref.value ||
-- autoPref.locked;
-+ var disable = true;
- updateModeLabel.disabled = updateMode.disabled = disable;
- },
-
-@@ -440,8 +439,7 @@
-
- var warnIncompatible = document.getElementById("warnIncompatible");
-
-- var disable = enabledPref.locked || !enabledPref.value || autoPref.locked ||
-- !autoPref.value || modePref.locked;
-+ var disable = true;
- warnIncompatible.disabled = disable;
- },
diff --git a/www-client/firefox/firefox-9999.ebuild b/www-client/firefox/firefox-9999.ebuild
index c446037..e098ee4 100644
--- a/www-client/firefox/firefox-9999.ebuild
+++ b/www-client/firefox/firefox-9999.ebuild
@@ -26,13 +26,13 @@ QA_PRESTRIPPED="usr/$(get_libdir)/${PN}/firefox"
src_prepare() {
# Gentoo specific stuff
epatch "${FILESDIR}"/gentoo-specific.patch
-
+
eprefixify \
extensions/java/xpcom/interfaces/org/mozilla/xpcom/Mozilla.java \
xpcom/build/nsXPCOMPrivate.h \
xulrunner/installer/Makefile.in \
xulrunner/app/nsRegisterGREUnix.cpp
-
+
# Gentoo install dirs
sed -i \
-e 's:$(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION):$(includedir)/idl:' \
@@ -40,7 +40,7 @@ src_prepare() {
-e 's:$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION):firefox:' \
"${S}"/config/autoconf.mk.in \
|| die "${MAJ_XUL_PV} sed failed!"
-
+
eautoreconf
cd js/src