aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/mozilla-app.eclass7
1 files changed, 6 insertions, 1 deletions
diff --git a/eclass/mozilla-app.eclass b/eclass/mozilla-app.eclass
index 6e5fc56..8006ab7 100644
--- a/eclass/mozilla-app.eclass
+++ b/eclass/mozilla-app.eclass
@@ -127,6 +127,11 @@ function mozilla-app_src_prepare() {
config/autoconf.mk.in \
|| die "${MAJ_XUL_PV} sed failed!"
+ # Avoid files deletion
+ sed -i \
+ -e '/remove/d' \
+ xpcom/idl-parser/header.py
+
eautoreconf
cd js/src
@@ -251,7 +256,7 @@ function mozilla-app_src_configure() {
--with-system-bz2 \
--with-system-zlib \
--disable-updater \
- --enable-system-cairo \
+ --disable-system-cairo \
--enable-system-hunspell \
--enable-system-ffi \
--disable-strip \