summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/xulrunner/xulrunner-9999.ebuild')
-rw-r--r--net-libs/xulrunner/xulrunner-9999.ebuild55
1 files changed, 6 insertions, 49 deletions
diff --git a/net-libs/xulrunner/xulrunner-9999.ebuild b/net-libs/xulrunner/xulrunner-9999.ebuild
index be90c53..49e229d 100644
--- a/net-libs/xulrunner/xulrunner-9999.ebuild
+++ b/net-libs/xulrunner/xulrunner-9999.ebuild
@@ -3,15 +3,8 @@
# $Header: $
EAPI="3"
-WANT_AUTOCONF="2.1"
-: ${EHG_QUIET:=OFF} # geeks prefer verbose stuff
-inherit flag-o-matic toolchain-funcs eutils prefix mozconfig-3 makeedit multilib pax-utils autotools python speed-mercurial
-
-EHG_REPO_URI="http://hg.mozilla.org/mozilla-central/"
-
-MAJ_XUL_PV="2.0"
-MAJ_FF_PV="4.0"
+inherit mozilla-scm
DESCRIPTION="Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications"
HOMEPAGE="http://developer.mozilla.org/en/docs/XULRunner"
@@ -19,43 +12,22 @@ HOMEPAGE="http://developer.mozilla.org/en/docs/XULRunner"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
SLOT="1.9"
LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE="+alsa debug +ipc libnotify system-sqlite +webm wifi"
+IUSE="debug"
RDEPEND="
- >=sys-devel/binutils-2.16.1
- >=dev-libs/nss-3.12.9
- >=dev-libs/nspr-4.8.7
- >=app-text/hunspell-1.2
- >=x11-libs/cairo-1.10.2[X]
- >=dev-libs/libevent-1.4.7
- x11-libs/pango[X]
- media-libs/libpng[apng]
x11-libs/libXt
x11-libs/pixman
- webm? ( media-libs/libvpx )
- alsa? ( media-libs/alsa-lib )
- libnotify? ( >=x11-libs/libnotify-0.4 )
- system-sqlite? ( >=dev-db/sqlite-3.7.4[fts3,secure-delete,unlock-notify] )
- wifi? ( net-wireless/wireless-tools )
- !www-plugins/weave"
+ >=dev-libs/libevent-1.4.7
+ !www-plugins/weave
+ "
DEPEND="${RDEPEND}
=dev-lang/python-2*[threads]
- dev-util/pkgconfig
dev-lang/yasm"
SRC_URI=""
S="${WORKDIR}/mozilla-central"
-pkg_setup() {
- # Ensure we always build with C locale.
- export LANG="C"
- export LC_ALL="C"
- export LC_MESSAGES="C"
- export LC_CTYPE="C"
-
- python_set_active_version 2
-}
src_prepare() {
# Gentoo specific stuff
@@ -108,8 +80,6 @@ src_configure() {
mozconfig_init
mozconfig_config
- MEXTENSIONS="default"
-
MOZLIBDIR="/usr/$(get_libdir)/${PN}-${MAJ_XUL_PV}"
# It doesn't compile on alpha without this LDFLAGS
@@ -207,12 +177,10 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ mozilla-scm_src_install
rm "${ED}"/usr/bin/xulrunner
- MOZLIBDIR="/usr/$(get_libdir)/${PN}-${MAJ_XUL_PV}"
- SDKDIR="/usr/$(get_libdir)/${PN}-devel-${MAJ_XUL_PV}/sdk"
if has_multilib_profile; then
local config
@@ -228,17 +196,6 @@ src_install() {
dodir /etc/env.d
echo "LDPATH=${EPREFIX}/${MOZLIBDIR}" > "${ED}"/etc/env.d/08xulrunner || die "env.d failed"
- # Add our defaults to xulrunner and out of firefox
- cp "${FILESDIR}"/xulrunner-default-prefs.js \
- "${ED}/${MOZLIBDIR}/defaults/pref/all-gentoo.js" || \
- die "failed to cp xulrunner-default-prefs.js"
-
pax-mark m "${ED}"/${MOZLIBDIR}/plugin-container
}
-pkg_postinst() {
- ewarn "This is experimental DO NOT file a bug report unless you can"
- ewarn "are willing to provide a patch. All bugs that are filled without a patch"
- ewarn "will be closed INVALID!!"
- einfo "Don't forget to rebuild firefox to update it to the same changeset"
-}