summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gnome-shell-dark-glass/gnome-shell-dark-glass-2010.01.09.ebuild')
-rw-r--r--x11-themes/gnome-shell-dark-glass/gnome-shell-dark-glass-2010.01.09.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-themes/gnome-shell-dark-glass/gnome-shell-dark-glass-2010.01.09.ebuild b/x11-themes/gnome-shell-dark-glass/gnome-shell-dark-glass-2010.01.09.ebuild
new file mode 100644
index 0000000..0e02d70
--- /dev/null
+++ b/x11-themes/gnome-shell-dark-glass/gnome-shell-dark-glass-2010.01.09.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+inherit base
+
+MY_PN="Dark-Glass"
+DESCRIPTION="Dark Glass Theme for Gnome-Shell"
+HOMEPAGE="http://half-left.deviantart.com/art/GNOME-Shell-Dark-Glass-Git-192828345"
+SRC_URI="${PN}.zip"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND="~gnome-base/gnome-shell-9999"
+DEPEND="app-arch/unzip"
+
+pkg_nofetch() {
+ einfo "Please download the ${SRC_URI} from"
+ einfo "${HOMEPAGE}"
+ einfo "and place it in ${DISTDIR}"
+}
+
+src_install() {
+ pushd "${WORKDIR}" &>/dev/null
+ mv theme ${MY_PN}
+ insinto /usr/share/gnome-shell/themes
+ doins -r ${MY_PN} || die "doins failed"
+ insinto /usr/share/gnome-shell/themes/${MY_PN}
+ doins "${FILESDIR}"/metadata.json
+ popd &>/dev/null
+}