summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2019-06-25 11:07:44 -0500
committerDaniel Solano Gómez <gentoo@sattvik.com>2019-06-25 11:07:44 -0500
commitfb7b403767ff2b97c050e05f555329eb51f881ac (patch)
treed9387cf8a2d088f0a11a56aaecd0855df93e10d4
parentAdd sci-electronics/digilent-adept-runtime (diff)
downloadsattvik-fb7b403767ff2b97c050e05f555329eb51f881ac.tar.gz
sattvik-fb7b403767ff2b97c050e05f555329eb51f881ac.tar.bz2
sattvik-fb7b403767ff2b97c050e05f555329eb51f881ac.zip
Add FTDI library
Signed-off-by: Daniel Solano <gentoo@sattvik.com>
-rw-r--r--sci-electronics/digilent-adept-runtime/Manifest1
-rw-r--r--sci-electronics/digilent-adept-runtime/digilent-adept-runtime-2.19.2-r1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/sci-electronics/digilent-adept-runtime/Manifest b/sci-electronics/digilent-adept-runtime/Manifest
index ba33fca..98224a0 100644
--- a/sci-electronics/digilent-adept-runtime/Manifest
+++ b/sci-electronics/digilent-adept-runtime/Manifest
@@ -1,3 +1,4 @@
DIST digilent.adept.runtime_2.19.2-x86_64.tar.gz 5774526 BLAKE2B 879b28bd729ded7aa7d7840323d140d0617650d6d3537dbf54e01004d8b72e0beece7e4e6b53988460235894ec26045b24a0da8306c1542aa044058591cc25ec SHA512 2d294c01c9a6d66aaba54b04f32a2eba66a58d1e1e00f38564ee18ac7d11053a6a862575e98043631571a1d84299edb9bf860162ac171777f47c6ef8d42652ba
+EBUILD digilent-adept-runtime-2.19.2-r1.ebuild 1365 BLAKE2B 93e910877866112857520f35f882ab07badac4409f95552bf7a3b94bdf0dc2cea89bfdb5d2fed9cd26554934169e627ca759d61c42f237a78a553ddae30a15ce SHA512 9ca7ce24ce4c0260383131afee713e2180b56c77346058e16e38ec3ece8bdd0671849d27ed9731f0456d8c1c5e6a62bfb74f06c785402fd796f02269564a7c5f
EBUILD digilent-adept-runtime-2.19.2.ebuild 1144 BLAKE2B 391425ff9ae89d1c673d5fddafb357c99a45429ed37ca5ed98ac1770f33647149a4c747a7a4bd3ecb3a5743ad48b51c9e7404b4687aa4e0c7c7a70d48433ce3a SHA512 384cf6593355373a8776fe573125be6f5184431f3971d9b418e9f9824359426416950fde62bbc42b98bd9ee91af56d3b763f30c01806afa8bda5a575bf70ef24
MISC metadata.xml 419 BLAKE2B 125ab7af072647a9c8fe7c35385c3881008a732c31bc753b3a87863a9f5119495c3373e73d6db6f69b957781a9cd2674638427bece674388c55e5214bc73a6f2 SHA512 c02093403ab20e23c01cf769177a64e2995d3594b51bcaed5083bbd9f69ac4ce35956e1015de1c4e38f42cfa4fa915a3846177434e80d228e9686e94b90c6de7
diff --git a/sci-electronics/digilent-adept-runtime/digilent-adept-runtime-2.19.2-r1.ebuild b/sci-electronics/digilent-adept-runtime/digilent-adept-runtime-2.19.2-r1.ebuild
new file mode 100644
index 0000000..f66a5d1
--- /dev/null
+++ b/sci-electronics/digilent-adept-runtime/digilent-adept-runtime-2.19.2-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+MY_PN=${PN//-/.}
+S="${WORKDIR}/${MY_PN}_${PV}-x86_64"
+
+DESCRIPTION="Allows communication with Digilent system boards"
+HOMEPAGE="https://reference.digilentinc.com/reference/software/adept/start"
+SRC_URI="https://s3-us-west-2.amazonaws.com/digilent/Software/Adept2+Runtime/${PV}/${MY_PN}_${PV}-x86_64.tar.gz"
+
+LICENSE="Digilent-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+QA_PREBUILT="*"
+RESTRICT="strip"
+
+src_install() {
+ (
+ insinto /usr/lib/digilent/adept
+ insopts -m0755
+ doins lib64/*
+ )
+
+ (
+ insinto /etc/ld.so.conf.d
+ doins digilent-adept-libraries.conf
+ )
+
+ (
+ insinto /usr/share/digilent/adept/data
+ doins data/jtscdvclist.txt
+ )
+
+ (
+ insinto /usr/share/digilent/adept/data/firmware
+ doins data/firmware/*.HEX
+ insopts -m0755
+ doins data/firmware/*.so
+ )
+
+ (
+ insinto /usr/share/digilent/adept/data/xpla3
+ doins data/xpla3/*.map
+ )
+
+ (
+ insinto /etc
+ doins digilent-adept.conf
+ )
+
+ dosbin bin64/dftdrvdtch
+
+ udev_dorules 52-digilent-usb.rules
+
+ # driver installation
+ (
+ insinto /usr
+ dolib.so ftdi.drivers_1.4.8-x86_64/lib64/libftd2xx.so.1.4.8
+ dosym libftd2xx.so.1.4.8 ${EP}/usr/lib64/libftd2xx.so.1
+ dosym libftd2xx.so.1.4.8 ${EP}/usr/lib64/libftd2xx.so
+ )
+}