summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2018-04-26 08:25:27 +0200
committerSven Eden <sven.eden@gmx.de>2018-04-26 08:25:27 +0200
commitd121b1a4296e89c0c089311f288d24f9c4b19ffb (patch)
treea36f365dc3227e978835dcd287ead6c22147f87a /dev-games
parentdev-games/ogre: Sync with PR preparation for real portage tests. (diff)
downloadseden-d121b1a4296e89c0c089311f288d24f9c4b19ffb.tar.gz
seden-d121b1a4296e89c0c089311f288d24f9c4b19ffb.tar.bz2
seden-d121b1a4296e89c0c089311f288d24f9c4b19ffb.zip
dev-games/ogre: The new pseudo-live ebuilds must set CMAKE_BUILD_TYPE. Otherwise installs are horribly incomplete.
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ogre/ogre-1.11-r20180423.ebuild11
-rw-r--r--dev-games/ogre/ogre-2.1-r20180420.ebuild9
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-games/ogre/ogre-1.11-r20180423.ebuild b/dev-games/ogre/ogre-1.11-r20180423.ebuild
index 7550b95..7e2bf1f 100644
--- a/dev-games/ogre/ogre-1.11-r20180423.ebuild
+++ b/dev-games/ogre/ogre-1.11-r20180423.ebuild
@@ -100,12 +100,11 @@ src_configure() {
-DOGRE_PROFILING=$(usex profile)
-DOGRE_RESOURCEMANAGER_STRICT=2
)
- # USE flags for features that do not work, yet
- # These components are off by default, as they might not be ported, yet.
- # When advancing to a newer commit, try whether any of the disabled
- # components can be activated now.
- mycmakeargs+=(
- )
+
+ # Ogre3D is making use of "CMAKE_INSTALL_CONFIG_NAME MATCHES ..." and
+ # sets it to BUILD_TYPE. Only RelWithDebInfo, MinSizeRel and Debug
+ # are supported.
+ CMAKE_BUILD_TYPE="$(usex debug Debug RelWithDebInfo)"
cmake-utils_src_configure
}
diff --git a/dev-games/ogre/ogre-2.1-r20180420.ebuild b/dev-games/ogre/ogre-2.1-r20180420.ebuild
index 2ef8751..df03ea3 100644
--- a/dev-games/ogre/ogre-2.1-r20180420.ebuild
+++ b/dev-games/ogre/ogre-2.1-r20180420.ebuild
@@ -16,7 +16,7 @@ LICENSE="MIT public-domain"
SLOT="0/2.1"
KEYWORDS=""
-IUSE="doc examples +freeimage gl3plus gles2 gles3 json ois +opengl profile tools"
+IUSE="doc debug examples +freeimage gl3plus gles2 gles3 json ois +opengl profile tools"
# USE flags for features that do not work, yet
# cg double-precision
@@ -104,6 +104,11 @@ src_configure() {
-DOGRE_BUILD_COMPONENT_VOLUME=NO
)
+ # Ogre3D is making use of "CMAKE_INSTALL_CONFIG_NAME MATCHES ..." and
+ # sets it to BUILD_TYPE. Only RelWithDebInfo, MinSizeRel and Debug
+ # are supported.
+ CMAKE_BUILD_TYPE="$(usex debug Debug RelWithDebInfo)"
+
cmake-utils_src_configure
}
@@ -128,7 +133,5 @@ src_install() {
if use examples ; then
insinto "${SHAREDIR}"
doins "${CMAKE_BUILD_DIR}"/bin/samples.cfg
- # The build system currently "forgets" to install these
- doins -r "${CMAKE_BUILD_DIR}"/Samples
fi
}