summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/bumblebee/bumblebee-9999-r4.ebuild (renamed from x11-misc/bumblebee/bumblebee-9999-r3.ebuild)0
-rw-r--r--x11-misc/bumblebee/files/bumblebee.envd6
-rw-r--r--x11-misc/bumblebee/files/nvidia-uvm-support.patch14
3 files changed, 17 insertions, 3 deletions
diff --git a/x11-misc/bumblebee/bumblebee-9999-r3.ebuild b/x11-misc/bumblebee/bumblebee-9999-r4.ebuild
index 8d7131f..8d7131f 100644
--- a/x11-misc/bumblebee/bumblebee-9999-r3.ebuild
+++ b/x11-misc/bumblebee/bumblebee-9999-r4.ebuild
diff --git a/x11-misc/bumblebee/files/bumblebee.envd b/x11-misc/bumblebee/files/bumblebee.envd
index e19cc56..59dfe1d 100644
--- a/x11-misc/bumblebee/files/bumblebee.envd
+++ b/x11-misc/bumblebee/files/bumblebee.envd
@@ -1,3 +1,9 @@
# Comment this out if you are using VirtualGL also for other purposes and this
# slows down things for you.
VGL_READBACK="pbo"
+
+# Workaround for Bumblebee no longer working with current mesa.
+# (See: https://github.com/amonakov/primus/issues/201
+# https://bugs.archlinux.org/task/58933
+# ) But only if the TearFree thing does not work...
+PRIMUS_UPLOAD=1
diff --git a/x11-misc/bumblebee/files/nvidia-uvm-support.patch b/x11-misc/bumblebee/files/nvidia-uvm-support.patch
index d002d80..54e8707 100644
--- a/x11-misc/bumblebee/files/nvidia-uvm-support.patch
+++ b/x11-misc/bumblebee/files/nvidia-uvm-support.patch
@@ -1,6 +1,6 @@
--- a/src/bbsecondary.c 2013-04-26 22:49:03.018174178 +0700
+++ b/src/bbsecondary.c 2014-11-11 20:14:32.663347521 +0700
-@@ -119,6 +119,17 @@
+@@ -119,6 +119,23 @@
if (!module_load(module_name, driver_name)) {
set_bb_error("Could not load GPU driver");
return false;
@@ -13,18 +13,26 @@
+ char log_string[1024];
+ sprintf(log_string, "Cannot load UVM module: %s\n", uvm_module_name);
+ bb_log(LOG_ERR, log_string);
++ /* Let's try the new nvidia-modeset if they have no uvm module installed: */
++ sprintf(uvm_module_name, "%s-modeset", module_name);
++ if (!module_load(uvm_module_name, "nvidia_uvm")) {
++ sprintf(log_string, "Cannot load MODESET module either: %s\n", uvm_module_name);
++ bb_log(LOG_ERR, log_string);
++ }
+ }
+ }
}
}
return true;
-@@ -232,6 +243,10 @@
+@@ -240,6 +257,12 @@
}
/* unload the driver loaded by the graphica card */
if (pci_get_driver(driver, pci_bus_id_discrete, sizeof driver)) {
+ /* XXX NVIDIA UVM support */
+ if (strstr(driver, "nvidia")) {
++ module_unload("nvidia_drm");
++ module_unload("nvidia_modeset");
+ module_unload("nvidia_uvm");
+ }
module_unload(driver);
- } \ No newline at end of file
+ }