summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Hickinbottom <stuart@hickinbottom.com>2015-08-16 16:50:06 +0100
committerStuart Hickinbottom <stuart@hickinbottom.com>2015-08-16 16:50:06 +0100
commit77cc9d7d90d407e5236935cd18d2f4cb601189a3 (patch)
tree43a00002ea40577a6e1a70e28e38bebf1054057d
parentAdded LMS 7.9.0 nightly 2015-08-12 (diff)
parentadd jivelite - 13 Dec 2014 snapshot (diff)
downloadsqueezebox-77cc9d7d90d407e5236935cd18d2f4cb601189a3.tar.gz
squeezebox-77cc9d7d90d407e5236935cd18d2f4cb601189a3.tar.bz2
squeezebox-77cc9d7d90d407e5236935cd18d2f4cb601189a3.zip
Merge branch 'jivelite-20141213' of https://github.com/lmiphay/gentoo-squeezebox-overlay into lmiphay-jivelite-20141213
-rw-r--r--licenses/jivelite57
-rw-r--r--media-sound/jivelite/Manifest1
-rw-r--r--media-sound/jivelite/jivelite-20141213.ebuild56
3 files changed, 114 insertions, 0 deletions
diff --git a/licenses/jivelite b/licenses/jivelite
new file mode 100644
index 0000000..acdc306
--- /dev/null
+++ b/licenses/jivelite
@@ -0,0 +1,57 @@
+JiveLite
+
+This program is a derivative of original code with the following license:
+
+Copyright 2010, Logitech, inc.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of Logitech nor the
+ names of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL LOGITECH, INC BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+Logitech copyright notices are retained in all files which were authored by Logitech.
+
+Grid layout code by GWENDESIGN / Felix Mueller
+
+Visualizer support based on code by presslab-us (https://github.com/presslab-us/jivelite)
+
+Jivelite ammendments and additional code:
+
+Copyright 2013-2014, Adrian Smith, triode1@btinternet.
+
+These additions are subject to the same license as above.
+
+Also includes image resize adapted from libgd - see source of resize.c for license.
+
+
+Repository also includes source for the following lua libraries. These are unchanged except for include file modification
+to support luajit-2.0 installed from source:
+and follow their own licenses:
+- cjson
+- luafilesystem
+- luaexpat
+- luamd5
+- luasocket
+
+Repository also includes the following additional skins:
+- Joggler, by "justblair" and others: http://www.justblair.co.uk/more-fixing-of-squeezeplay-for-the-joggler.html
+
diff --git a/media-sound/jivelite/Manifest b/media-sound/jivelite/Manifest
new file mode 100644
index 0000000..0fa8a42
--- /dev/null
+++ b/media-sound/jivelite/Manifest
@@ -0,0 +1 @@
+EBUILD jivelite-20141213.ebuild 1121 SHA256 ae20bc91f296810bd436bf0a78dfe0e58cd257f9884b76b0121956278f05322a SHA512 e5b489a4fdb2b14b8aa9b41bfa643e5775fc44bcf5db946cfca6300f57d1d44772afa370ef2bc44d5981c3feffd3d7a94f7718b69a5fdc4c1c13d31d4a4ac992 WHIRLPOOL 04aeba85f7782f3f3953d9ab7628bfbfb6d8a497006d5b8dad1b5579ac943b10049ff9a80e36ab2b17eedd29ef79351e2e487ef660e7485ace462905c36a1f5e
diff --git a/media-sound/jivelite/jivelite-20141213.ebuild b/media-sound/jivelite/jivelite-20141213.ebuild
new file mode 100644
index 0000000..973e446
--- /dev/null
+++ b/media-sound/jivelite/jivelite-20141213.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils git-r3
+
+DESCRIPTION="Experimental squeezebox and derivative control application"
+HOMEPAGE="https://code.google.com/p/jivelite/"
+
+EGIT_REPO_URI="https://code.google.com/p/jivelite/"
+EGIT_COMMIT="de07c79a717fa678d8ae8d87f5ef41d16357949b"
+
+LICENSE="jivelite"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-lang/luajit
+ dev-lua/lua-cjson
+ dev-lua/luacrypto
+ dev-lua/luaexpat
+ dev-lua/luafilesystem
+ dev-lua/luasocket
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-ttf
+ media-libs/sdl-gfx
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's;-lpthread;-lpthread -lrt;' "src/Makefile"
+ sed -i -e 's;"arp ";"/sbin/arp ";' "share/jive/jive/net/NetworkThread.lua"
+ epatch_user
+}
+
+src_compile() {
+ emake -C src PREFIX=/usr
+}
+
+src_install() {
+ dobin bin/jivelite
+ insinto /usr/share/jive
+
+ doins -r share/jive/jive
+
+ doins -r share/jive/fonts
+ doins -r share/jive/applets
+
+ for i in loop ltn12.lua lxp mime.lua socket socket.lua ; do
+ doins -r share/lua/5.1/$i
+ done
+}