summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortocaro <tocaro@thocar.org>2015-01-10 19:50:30 +0100
committertocaro <tocaro@thocar.org>2015-01-10 19:50:30 +0100
commitd778d154020820be614f91eeab16d33072323a03 (patch)
tree4f23777590ce61911bdd38289085faae47801f39 /app-admin/tho-puppet-bootstrap/tho-puppet-bootstrap-0.2.0.ebuild
parentadding new package to use puppet via git without a puppet server (diff)
downloadtocaro-d778d154020820be614f91eeab16d33072323a03.tar.gz
tocaro-d778d154020820be614f91eeab16d33072323a03.tar.bz2
tocaro-d778d154020820be614f91eeab16d33072323a03.zip
support for hiera in puppet bootstrap
Diffstat (limited to 'app-admin/tho-puppet-bootstrap/tho-puppet-bootstrap-0.2.0.ebuild')
-rw-r--r--app-admin/tho-puppet-bootstrap/tho-puppet-bootstrap-0.2.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-admin/tho-puppet-bootstrap/tho-puppet-bootstrap-0.2.0.ebuild b/app-admin/tho-puppet-bootstrap/tho-puppet-bootstrap-0.2.0.ebuild
new file mode 100644
index 0000000..b04caf8
--- /dev/null
+++ b/app-admin/tho-puppet-bootstrap/tho-puppet-bootstrap-0.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2013-2014 Thomas Carrie
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="If you want to use puppet without the puppet server, you can use it via git with a recent puppet setup via rubygems"
+HOMEPAGE="http://thocar.org/tarballs/"
+SRC_URI="http://thocar.org/tarballs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm x86"
+IUSE=""
+DEPEND=""
+RDEPEND=">=dev-vcs/git-1.7.0
+ virtual/rubygems"
+
+src_install() {
+ # http://devmanual.gentoo.org/function-reference/install-functions/
+ dobin thoPuppetBootstrap
+}